Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

B1414+ Bug Reporting Thread


#221

not sure if this is the same but I was doing the weiron 1200bs scenario and tried to change my engine configuration from twin turbo to N/A and as soon as I clicked N/A I got this error


Lua Error:

tolua++ dbcall failed!: [string “–client\functional\EngineCombustion_Aspira…”]:782: attempt to index field ‘Intercooler’ (a nil value)

any help would be appreciated


#222

Keep pressing okay until it changes to retry/cancel then press retry, between errors click naturally aspirated, click retry and n/a a few more times and the error will clear and you can keep building. It happens when removing turbos to engines from older builds which sadly the scenarios are.


#223

I’m not sure if this bug was supposed to be fixed or not.I ecountered it in B1415

Here’s an unnecesairly detailed description of what i did before ecountering it:I made some variations of the first avaible body and clicked new car.I went down to 1940 quicly made a platform switched to body selection and changed year to 1950 and then to 1960.After that i changed years 1 by 1 to 1954 and then 1955(thats when new bodies are availble).And then i went back to platform tab.that’s when it happened



#224

Maybe this is just some elaborate ruse and they’re building up hype for B1500 which introduces literal bulldozers into the game.


#225

… Didn’t you sign the NDA!!!


#226

[quote=“Jakgoe”]

… Didn’t you sign the NDA!!![/quote]

OH NOES, NOW THAT IT’S LEAKED WE HAVE TO CANCEL BULLDOZERS :laughing:


#227

[quote=“Jakgoe”]

… Didn’t you sign the NDA!!![/quote]

yeah with my fingers crossed behind my back

[quote=“Daffyflyer”]

… Didn’t you sign the NDA!!!

OH NOES, NOW THAT IT’S LEAKED WE HAVE TO CANCEL BULLDOZERS :laughing:[/quote]

Eh I mean I’m not that upset, can you imagine how long it would take for a bulldozer to go around the test track? God that would be awful.


#228

That would put the “time acceleration” feature request higher up on everybody’s list xD


#229

[quote=“Killrob”]

That would put the “time acceleration” feature request higher up on everybody’s list xD[/quote]

Flux capacitors confirmed for B1416?

God that would make Material Cost skyrocket.


#230

In B1416, multiplayer does not work. It says that the game version is too old.


#231

On B1416 in Scenario whenever I click on the engine type (V8, I6, General, I4, whatever) I get this error, but I can continue.


Lua Error:

tolua++ dbcall failed!: [string “–client\functional\CScenarioWindow.lua…”]:376: attempt to index a nil value

You can CTRL+C on this to report it.

OK

I then get this one when I actually pick the scenario to play, but can again sort of continue. The scenario then has issues, like the wrong year selected, doesn’t seem to have actual requirements or anything.


Lua Error:

tolua++ dbcall failed!: [string “–client\functional\engineWizard.lua…”]:1385: attempt to index field ‘EngineFunc’ (a nil value)

You can CTRL+C on this to report it.

OK

edit: When I actually try to run a test on an engine, I get this one.


Lua Error:

Step() failed!: [string “–client\functional\engineWizard.lua…”]:1933: attempt to perform arithmetic on field ‘FailedAttemptCounter’ (a nil value)

You can CTRL+C on this to report it.

Retry Cancel


#232

Found another, this one in B1415 (I downgraded so I could play). If you have a turbocharger and then remove it, you get an error. This was on the V8 Endurance Race thing, but I imagine it’s widespread.


Lua Error:

tolua++ dbcall failed!: [string “–client\functional\EngineCombustion_Aspira…”]:782: attempt to index field ‘Intercooler’ (a nil value)

You can CTRL+C on this to report it.

OK


#233

That’s pretty bad and needs a fix soon, thanks for posting!


#234

[quote=“pedalforce”]Found another, this one in B1415 (I downgraded so I could play). If you have a turbocharger and then remove it, you get an error. This was on the V8 Endurance Race thing, but I imagine it’s widespread.


Lua Error:

tolua++ dbcall failed!: [string “–client\functional\EngineCombustion_Aspira…”]:782: attempt to index field ‘Intercooler’ (a nil value)

You can CTRL+C on this to report it.

OK
---------------------------[/quote]

Until there’s a fix on this, I just cope by pressing the retry button and manually removing the intercooler. The error should stop if you’re patient enough to even get the intercooler off. :slight_smile:


#235

So, today it offer’s me Build 1417. I didn’t think twice about it, thinking maybe it fixed multi-player mode, but now I cannot start the game. It required a restart of my laptop, and then offers Build 1417 again. I checked here and see no announcements about this build? Currently uninstalling and gonna download the game again.


#236

I just got offered B1417 as well. I downloaded and installed it, and the game still works for me.


#237

B1417 fixed the scenario bugs and turbo-to-NA errors. There should be no problem with the install though :s it worked fine on all systems we tested it on (which are not many though).


#238


#239

That will be an easy fix as soon as Caswal is back, it’s just changing one number server-side, I think.


#240

After complete deletion of game/files, and a reinstall of launcher, it works for me as well. It just wouldn’t work from 1416>1417 for some reason. It appears the 1417 install first downgraded to 1415, but then wouldn’t update to 1417 until I reinstalled all of it. It just kept “offering” to update…