Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

B1414+ Bug Reporting Thread


#281

I have verified this as I’ve built a small turbo V8 and a midsize turbo Inline 6. All my problems were using the large mid-engined body with the engine set to mid-longitudional… When I use other bodies (including the new ones) I have no errors or troubles making turbo engines.


#282

Hi, new player here. Just downloaded and updated from the launcher (Build 1418) but my game had a lot of trouble launching. It seemed to build the engine then stop while the music plays on and all I could interact with is the error message. I got the following errors over my experience which is documented in segmants below. I didn’t grab a screen shot for every single error but everything I did see is here in text form.

Starting with my first installation


Lua Error:

[string “–client\start scripts\init.lua…”]:713: attempt to call method ‘Setup’ (a nil value)

Retry / Cancel

& if you hit Retry (seems to say that for most re-tried errors)


Lua Error:

Step () failed!:[string “–client\functional\TimelineManager.lua…”]:341: attempt to index global ‘ModelDesigner’ (a nil value)

You can CTRL+C on this to report it.

Retry / Cancel

Re-installing didn’t fare much better either. The error described earlier has been replace by:


Lua Error:

[string “–client\start scripts\init.lua…”]:679: attempt to index global ‘CScenarioSuccess’ (a nil value)

Retry / Cancel

Another re-install. engine building loading screen reached later phase but did not complete;


Lua Error:

[string “–client\start scripts\init.lua…”]:863: attempt to index global ‘CScenarioSuccessMulti’ (a nil value)

Retry / Cancel

Next Re-install seems to go back a phase with the error being:


Lua Error:

[string “–client\start scripts\init.lua…”]:691: attempt to index global ‘CScenarioHints’ (a nil value)

Retry / Cancel

Another attempt.


Lua Error:

[string “–client\functional\engineWizard.lua…”]:1549: attempt to call method ‘new’ (a nil value)

Retry / Cancel

Game finally started. Bit of an ominous beginning but if all it takes is 4-5 re-installations, then I suppose it’s worth a try.


#283

Hi,

I encountered a freeze with the following error message :


Lua Error:

tolua++ dbcall failed!: [string “–shared\functional\SCEN_DATA_B305\CEngineCal…”]:1608: attempt to index local ‘EngineDimensions’ (a nil value)

You can CTRL+C on this to report it.

OK

It occured when I clicked on the the motor test button during iCar scenario

Rgds,
Frantz


#284

Not 100% sure that this is a bug, but for whatever reason I cannot fit an engine in longitudinally in the 10s Hatchback body.
Not even a 323cc I4.


#285

Why does the save car button just not work sometimes? I’m tired of losing my work due to this!

EDIT: Please disregard this post. I left the safety part in one of my cars empty, that’s why my car wouldn’t save.


#286

So I was building up my 89 Comrade Clunker for np1993’s Underground Cup when I had the wild idea to re-use the 'Murican V8 from my 67 IT/A entry.

After being pelted with a series of error messages, I was left with this.

Another angle, with ‘proper’ engine specs

Sequential carburetors? Why not!

If you try and change any of the original configurations, it guns you down with threats like this

This happened with B1418. I’m guessing this occurred due to the conflicting years (1967 vs 1989)


#287

Hi

The game froze and gave me an error message when testing the engine for the gallileo


Lua Error:

tolua++ dbcall failed!: [string “–shared\functional\SCEN_DATA_B305\CEngineCal…”]:1608: attempt to index local ‘EngineDimensions’ (a nil value)

You can CTRL+C on this to report it.

OK


#288

Everytime i click on the engine block for the number cylinders the game crashes, I get the following error.

tolua+ + DBcall failed: [string “–client\functional\Enginecombustion_Asprirati…”]:306: attempt to call method ‘UpdateTurboSplinesinline’ (a nil value)

click OK and get

stepfailed() failed: [string “–client\functional\Enginecombustion_Asprirati…”]:306: attempt to call method ‘UpdateTurboSplinesinline’ (a nil value)

Please help
This happens in Snadbox mode


#289

[quote=“Jayphils”]Everytime i click on the engine block for the number cylinders the game crashes, I get the following error.

tolua+ + DBcall failed: [string “–client\functional\Enginecombustion_Asprirati…”]:306: attempt to call method ‘UpdateTurboSplinesinline’ (a nil value)

click OK and get

stepfailed() failed: [string “–client\functional\Enginecombustion_Asprirati…”]:306: attempt to call method ‘UpdateTurboSplinesinline’ (a nil value)

Please help
This happens in Snadbox mode[/quote]

Though it isn’t my place to be answering things like this, are you creating a brand new engine or are you changing from an Inline to a V setup?


#290

New engine, it happens as soon as I click on it


#291

Lua Error:

tolua++ dbcall failed!: [string “–client\functional\CarView.lua…”]:2781: attempt to index local ‘headLightInfo’ (a nil value)

I get this message every time np1993 tries to send me his entry to the ATCC .

If someone could explain me what is going on, I will be very happy+


#292

Hey, I have been getting THIS error whenever I go to select a grill and place it on a model OR anything else to do with a grill.

tolua++ dbcall failed !: [string '–client\functional\PlatformDesignerWindowDel…"]:1334: attempt to index a nil value


#293

I did a uninstall and re-install and now I am getting this error:

toloua+ + dbcall failed!: [string “–shared\functional/SANDBOX_DATA\CCarCalculat…”]116attempt to index local ‘family’ (a nil value)


#294

I also get this error when I try and adjust suspension settings.


#295

I got this error when I selected previously created engine (1.6, 6cyl turbo with 360HP) at the car creation. So I designed a mid-engine sport car and on engine list I clicked on “choose” and that was it, it froze there.

EDIT: Ok, my game is now broken and I can’t play it :frowning:
So, I’ve created a compact class car and then I wanted to make a sporty version of it. I’ve chose to revise it and once I was done with small cosmetic changes I clicked on “trim”. It said that the engine is to big (and it can’t be since it didn’t even give me a chance to change, and it was 1.0l). Game crashed with:


Lua Error:

tolua++ dbcall failed!: [string “–shared\functional\SANDBOX_DATA\CCarCalculat…”]:146: attempt to index field ‘EngineInfo’ (a nil value)

And now it just freezes when I click on Sandbox and I can’t play any more… Did anyone had similar problem?

EDIT2: The lesser error is fixed by deleting car model from Documents folder.


#296

I’ve seen that first error before, not sure what I did to cause it, but when I close and reload the game it disappears.


#297

Sounds like the car file simply got corrupted. Good to go now? If not, you might need to completely uninstall and reinstall Automation.


#298

I posted this in it’s own thread on the support page, but here it is again: I found this game today, and planned on purchasing it, but as I was playing the demo to test out the game, I found out that I couldn’t zoom effectively. It might be that I’m playing on my laptop, but, I tried to zoom in using my mouse pad’s scroll wheel effect (placing two fingers on the mouse pad and moving them to zoom) and it either zoomed in too far or zoomed out too far, and I couldn’t get it just right, and if I did get it right it would slowly zoom in or out and it’s just annoying. I tried using the + and - buttons, and that worked until I accidentally hit the mouse wheel effect on my mouse pad and it started zooming in very slowly again and the + and - buttons wouldn’t work after that. I was wondering if there is a possible fix to this, or perhaps the game developers could put a set zoom level on the screen or have some kind of in-game option for zooming. Anyone that could help me, I would appreciate it. Unfortunately, this has deterred me from purchasing the game.

Any help?


#299

I have something that is not really a big bad bug, and it may be something wrong with my machine, but I’d rather say there’s something wrong on line or multiple line of code. I have a super charged engine (to be exact so you can recreate, one of the engines I made), and whenever I re-enter the engine editor, the Supercharger fan’s size goes from the preset 0.1mm down to custom and the maximum pressure 0.01 PSI down too, which results in a 1HP of difference.


#300

[quote=“jesselawenforcement”]I posted this in it’s own thread on the support page, but here it is again: I found this game today, and planned on purchasing it, but as I was playing the demo to test out the game, I found out that I couldn’t zoom effectively. It might be that I’m playing on my laptop, but, I tried to zoom in using my mouse pad’s scroll wheel effect (placing two fingers on the mouse pad and moving them to zoom) and it either zoomed in too far or zoomed out too far, and I couldn’t get it just right, and if I did get it right it would slowly zoom in or out and it’s just annoying. I tried using the + and - buttons, and that worked until I accidentally hit the mouse wheel effect on my mouse pad and it started zooming in very slowly again and the + and - buttons wouldn’t work after that. I was wondering if there is a possible fix to this, or perhaps the game developers could put a set zoom level on the screen or have some kind of in-game option for zooming. Anyone that could help me, I would appreciate it. Unfortunately, this has deterred me from purchasing the game.

Any help?[/quote]

To be honest, that’s to be expected with a mousepad. I’ve gotten that problem on every application I use with both of my laptops I have currently. Both scrolling and zooming make it zoom too far.