Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Can't interact with Right side of screen


#1

As the title says, I can’t interact with any of the options, menus or button on the right third of the screen. I don’t have any sort of event log since it doesn’t cause the game to crash. It’s been a while since I have been on the game, but some I’m guessing some update over the last few months has caused this. It happened first to my knowledge about a month ago, and then I tried again today to no improvement. Natively I run 1920 x 1080 in borderless window mode, but I’ve also tried lower resolutions to no avail and putting it into windowed mode which just causes my computer to go into sleep mode. (I saw there’s a post for that one so I will read that on my own.) Any help is appreciated, I don’t know what else to try or if this is affecting anyone else.

  • Cheers,
    Racer13

#2

Have you…
Verified the game files in Steam?
Tried new video drivers?
Tried reinstalling the game?


#3

I have not tried any of those, however my video drivers should be up to date. How would I go about verifying the files in Steam?


#4

in your steam library, right click the game and select properties
In the properties box, select the local files tab, verify integrity of game files is the 2nd to last option.

Click that and allow it to run.


#5

I just verified the files and it came back with ‘1 file failed to validate and be reacquired’. So is this sorted now or do I need to reinstall to get that file?


#6

It should have done that automatically for you


#7

So far nothing has worked, so I guess it’s time to try reinstalling.


#8

Reinstalling won’t work, as that is more or less the same as verifying the files.
No idea what could cause this issue, I believe it is the first time someone reports on this. When you set the game to windowed mode via the main game’s options menu. That should NOT put the computer to sleep or crash your graphics card unless something is seriously wrong on your system. It would be interesting to see if a small window does the same thing.


#9

Yeah, I just tried reinstalling that didn’t work either. Could having workshop content installed have any affect on this? The strange thing is it doesn’t entirely block out the right side of the screen, just most of it. For example in the car editor I can select the buttons at the top right corner of the screen, but nothing else below that.


#10

That is highly unlikely, workshop stuff is just content, it doesn’t change the game. :slight_smile: What you are describing sounds like an input issue. Maybe it is something like a mouse driver issue? You could try to switch off hardware acceleration for your mouse or something, maybe you have such an option. Other than that, I’d indeed try window mode to see if that has the same issue.


#11

Perhaps it is mouse related, although I’m not sure how it would cause it. But I did upgrade my mouse during the time that the problem occurred, from a simple Logitech wireless mouse to a Corsair M65. I’ll mess around with acceleration settings and then try windowed mode. I’m hesitant to try windowed mode again because when I tried it last night it instantly set my computer to sleep mode for some reason forcing me to restart my computer. In either case I’ll give them both a shot and report back.


#12

So I turned off mouse acceleration in Windows 10 and the problem has slightly resolved itself, by which I mean I can now select the buttons in the bottom right corner of the main menu, but only when my mouse is at the very bottom of the button, move it up about 10 pixels and it stops working again.


#13

Running in windowed mode doesn’t seem to help either. The problem seems to persist. Any other ideas?


#14

From what you have discovered so far it looks like a mouse driver issue. Are there any updated drivers for the mouse you are using? Do you have any other mouse lying around to try out?


#15

Not working ones unfortunately. I’m updating my mouse drivers now, hopefully that solves the issue. It’s a very strange problem if that’s what it is.


#16

I am having this exact same issue. Did all the common fixes including updating .NET Framework and Video adapter driver…no change.

Is there a way to adjust the launcher’s resolution?


#17

Go into your Steam library and try it this way.

Capture

Out of curiosity, what’s your screen resolution set to?


#18

That works and I have been using the game that way using the “.exe” found in the “Windows no editor” file. As it says though it seems there are no options (like finding mods I’ve subscribed to in the workshop).

My screen res. is 1280x1024


#19

I tried launching without the options menu, didn’t help. And I’m running at the standard 1920x1080.


#20

We fixed windowed mode :slight_smile: So give the problem another go for you mouse problems!

At you others: we’ll have a look into that launcher resolution thing!
@bluebrew are you by chance running some weird windows DPI settings (Scale & Layout in the Display settings)? We gave that a go and all kind of weird things start to happen to it :stuck_out_tongue: