Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Crash at launcher


#1

My game is crashing at the launcher. I tried searching for countless hours but to no avail! I have windows 10. Heres the log.
[22:59:46] Lua: escripts MD5Sum: c35da9e4cd0c2791c702f4a19ff1cdf6
[22:59:46] Lua: Lua Version: “Lua 5.1”
[22:59:46] Lua: LuaJIT 2.0.3
[22:59:46] Lua: Starting initialization process…
[22:59:46] Lua: Game Version: 170116
[22:59:46] Lua: Loading User Settings
[22:59:46] Lua: No Unit Settings, Defaulting to Metric
[22:59:46] Lua: Loading Display Settings from XML
[22:59:46] Lua: Unable to load/find DisplaySettings.xml – Defaulting
[22:59:46] Lua: --------------------------------------
[22:59:46] Lua: Display Settings:
[22:59:46] Lua: Resolution: 1680 x 1050
[22:59:46] Lua: Mode: Windowed
[22:59:46] Lua: SSAO: true
[22:59:46] Lua: FXAA: false
[22:59:46] Lua: Viewport Res: 1
[22:59:46] Lua: --------------------------------------
[22:59:46] Lua: Starting Kee Engine…
[22:59:46] Engine: Loading Resource Kee.dll
[22:59:46] Engine: Creating Viewport Manager Instance
[22:59:46] Engine: Engine initialisation: WindowManager - Created
[22:59:47] Engine: D3D ERROR: D3DERR_NOTAVAILABLE
DESCRIPTION:
Not available
[22:59:47] Engine:
[22:59:47] Engine: resizing window: width 1680, height 1011
[22:59:47] Engine: Engine initialisation failed. Could not initialise render manager.


#2

What is your GFX card?


#3

NVIDIA Geforce GTX 750, 2GB (2048MB) of Video Ram.


#4

Update video drivers and try changing the game screen resolution in Options.


#5

Also try this:
http://steamcommunity.com/app/293760/discussions/0/610574827763786630/

as it could be that you don’t have the correct DX9 libraries.


#6

Did both and still nothing.


#7

When was the last time you played that it worked? Have you installed anything new?


#8

well over 2 months ago. Did a few fresh installs of the game. Biggest thing that happened to my computer was a full factory reset.


#9

Did you install the latest gfx card drivers after that reset? Have you tried to run the game in windowed mode at 1280x720?


#10

tried that already as well. sorry for the late response!


#11

And you’ve tried full screen? Just checking


#12

it only gives me a windowed and borderless option.


#13

I cant start the game.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly ‘Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified.
File name: ‘Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at Automation_Launcher.Optionsform.HasAnyValidResolutions()
at Automation_Launcher.AutomationLauncherWindow.Form1_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

Automation Launcher Steam
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Automation/Automation%20Launcher%20Steam.exe

System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

System.Core
Assembly Version: 3.5.0.0
Win32 Version: 3.5.30729.8795 built by: WinRel
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Core/3.5.0.0__b77a5c561934e089/System.Core.dll

Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8784 (WinRel.050727-8700)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


#14

This should solve the issue:
http://steamcommunity.com/app/293760/discussions/0/610574827763786630/