Home | Wiki | Discord | Dev Stream | YouTube | Archived Forums | Contact

Game doesn't remember display settings


#1

I play on an ultrawide 5210x2160 and prefer fullscreen mode. The game does work fine, although the UI and some other things/graphics do seem a bit oddly placed on this resolution/aspect radio, but nothing game-breaking. But, when I re-launch the game, it defaults back to windowed mode. I’m not sure if it’s also an issue with other display sizes/resolutions, but I do find it a tad annoying having to set the graphics back to fullscreen all the time. The weird thing is that sometimes (rarely!) it does remember and starts in fullscreen. It has nothing to do whether the game crashes or is exited properly - either way most of the time it reverts to windowed, but not always.


#2

Heyya!
Sorry for the late reply. This is something that many have pointed out, it seems like those settings either aren’t saved correctly or are being overwritten when they should not. We’ll investigate :slight_smile: I’ve put it on our list.


#3

The problem was fixed, but is back now with the LVC4 Openbeta version. It now also resets the resolution to 2275x1421 (what an odd choice to reset to). So each launch I have to go back and redo the graphics settings.


#4

You have cleared your game cache already and the problem persists?


#5

Yep, and the problem persists. Also, now at 5210x2160 the tabs “windowed” “full screen windowed” and “full screen” don’t do anything. At that resolution it’s stuck on “full screen”. Clicking “apply” with any others doesn’t do anything.


#6

We looked into the issue and while we can’t reproduce it ourselves, we potentially have a fix for it. Could you once the next patch hits try if it still is an issue?


#7

All right, there is a positive development with the patch today! It’s still a bit wonky, but the good news is that it remembers my settings when I restart the game. The wonky parts are:

  • on “windowed” the largest resolution available to me is 3413x2133 with the default being 1280x720. All available resolutions work as intended, with the window of the game resizing itself to match the chosen resolution.
  • when in “windowed” mode, I can still click the “maximize window” button (the middle square button at the top right between the “X” to close the window and the “_” to minimize, in case my description is not clear). The game does maximize to full screen windowed, and I’m pretty sure it displays at the screen’s native resolution (5120x2160) - sharp as a tack. For all intents and purposes, this is “fullscreen windowed” in my books.
  • on “fullscreen windowed” mode, I have access to all resolutions up to and including 5120x2160, but it doesn’t in fact display fullscreen windowed or alter the resolution - it’s just fullscreen at the screen’s native resolution, regardless what settings I pick. Sharp as a tack though.
  • on “fullscreen” it indeed displays fullscreen, and I have access to all resolutions, and they all work as intended with black bars on the side for non-ultra-wide settings, and getting blurrier as resolution drops. That said, at the full 5120x2160 in this mode is actually slightly blurrier than the other two modes when forced to be fullscreen - an anti-aliasing thing perhaps?

Let me know how else I can help, would a dxdiag with my setup help you in any way to sort this out?

edit: I should add build numbers to these posts… this one is 200328.12267.2038.Manual


#8

I had the same kind of problem as cake_ape were my 1440p resolution would always reset to 1080p when I restarted the game. I had this problem for a relatively long time (>6 months)

However since LVC4.0 hotfix 1 or 2 the problem seems to be resolved. I didn’t even have to clear the cache memory.

I added this just so that you know that, whatever you changed, worked for at least some people.


#9

Excellent! :slight_smile: Thanks for letting us know.