Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Modding Tutorial 2 - Taillights


#21

The verts doesn’t move. How I can fix this?


#22

[quote=“vmo”]

The verts doesn’t move. How I can fix this?[/quote]

So you’ve weighted the verts to the dummies, but when you move the dummies the verts don’t move?


#23

[quote=“Daffyflyer”]

The verts doesn’t move. How I can fix this?

So you’ve weighted the verts to the dummies, but when you move the dummies the verts don’t move?[/quote]

What is weighted?

And, yes, when I move the dummies, the verts don’t move.


#24

I seem to have run into the same issue as Felgen.

Everything exports fine, I get no LUA errors but the taillight looks like this:

Tried just putting the back from a random taillight in there and it worked, so I imagine it’s something with my model.


#25

First off, from the way the taillight looks like, it almost looks as if it’s oriented the wrong way. Also, make sure the UV mesh’s verts are perfectly overlapping with the casing outline’s verts.

Also, I see an MX-5 in works. Taillights that I think were intended to look like those of an MX-5 were in the first car designed beta versions, but they haven’t made it to the public version.


#26

Thanks, the issue was caused by the UV mesh.

I changed the shape of the light slightly w/o editing and re-exporting the UV mesh.

Just remade the UV mesh and now it works perfectly.

As for it being upside down, it wasn’t. But since the model of both headlights and taillights are in the same direction in 3DS Max, the game probably made it appear like that by default when it was unable to associate it to a UV mesh. It might also be why some lights and mufflers get stamped the wrong way on surfaces that are normal to the Z axis.


#27

When I try to export the textured headlight, 3ds max crash (inclusive the sample tailight).

I’m using 3ds max design 2013 x86 in windows 8.1.

The issue doesn’t occurs when I’m exporting the headlight without skeletons and animations.


#28

Just to be sure, it crashes when exporting a part with skinning (morphs)?

Necron had a similar problem and it was fixed by replacing Replaced the KajiraExport.dle file with the KajiraExport_2013.dle file.


#29

Ok. I will try. Thanks.

EDIT: Thanks! It works!

I installed 3ds max 2013 and unistalled 3ds max design 2013.


#30

Hi eveyone! I wanted to create my own first taillight, and of course Ive stucked up. I dont know what it is. I think that I done everything like in the tutorial (but probablly not).

First thing, I create my own materials, beacuse I couldnt import the sample file, I have 3ds max 2010. My light is all in one colour (material) and its
shining like a chrome or mirror or something like that. Can enyone help me with this problem? I would be pleased.

P.S. Sorry for my rough English and also I`m using 3ds (any modeling software) for about 2 days, so please try to explain to me like to a super novice user.

http://imageshack.com/a/img538/5409/n1MQCZ.jpg


#31

Please, post the lua file.


#32

In attachment it`s ok?
parts.lua (793 Bytes)


#33

Do you put in 3DS Max, in the glass, the material 5, GlassSmooth?


#34

Well I guess no, beacuse like I mentioned I couldn`t import sample file, so I created materials on my own. Is there any option to get this material 5 GlassSmooth?


#35

Get the Youtube Automation official tutorials sample files.


#36

But these samples wont work with 3ds max 2010, amI right? Maybe exporting only materials will work. I mean, somebody who has 3ds 2013 export this materials to file and then I think I will be able to import these materials. It is possible?


#37

[quote=“Chucky”]Hi eveyone! I wanted to create my own first taillight, and of course Ive stucked up. I dont know what it is. I think that I done everything like in the tutorial (but probablly not).

First thing, I create my own materials, beacuse I couldnt import the sample file, I have 3ds max 2010. My light is all in one colour (material) and its
shining like a chrome or mirror or something like that. Can enyone help me with this problem? I would be pleased.

P.S. Sorry for my rough English and also I`m using 3ds (any modeling software) for about 2 days, so please try to explain to me like to a super novice user.

http://imageshack.com/a/img538/5409/n1MQCZ.jpg[/quote]

Remember that you need to use the right textures if you want to use the ECS_TAILLIGHT material. Moreover, only the glass material can be transclusent, and a conventional ECS_STANDARDMAT can only be inherently opaque.


#38

in another words, with out proper materials settings in my 3ds max project, I won`t be able to create proper taillights? Do I must have sample files materials
to do it?

Or there is some way to create materials simillar to these in sample file (sample file=delivered by Automation dev)? I have 3ds 2010 so I can`t open these
sample files.


#39

[quote=“Chucky”]in another words, with out proper materials settings in my 3ds max project, I won`t be able to create proper taillights? Do I must have sample files materials
to do it?

Or there is some way to create materials simillar to these in sample file (sample file=delivered by Automation dev)? I have 3ds 2010 so I can`t open these
sample files.[/quote]

You need to use the mapped materials from the sample files.

Don’t worry: tomorrow I will convert the files into 3DS Max 2010 for you and all users.


#40

Oh men, that would be great for all of us. So I am waiting unpatiently.