Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

[SOLVED, bonus question inside] My custom track doesn't want to work


#1

Hello,

I’m trying to achieve best acceleration and I wanted to make a simple custom track, a straight line of 1 mile with sector 1 at 1/4 of mile and sector 2 at 1 Km.

I used http://bmarques.net/automation-track-builder/ to do it. It did not work so I downloaded the Github folder with all custom tracks and compared the code. I tired several variations (1 segment, 10 segments, 0 or STRAIGHT, etc.) but none would work.

When I click on the “Play” button to launch the sim, spinning logo appears and stay spinning. Indefinitely.

Could please someone check this and tell me what’s wrong with this ?

--You Can use 0, 1, -1 instead.
local STRAIGHT = 0
local LEFT = 1
local RIGHT = -1

Track = {
		Name = "Simple Dragstip",
		--Track Image Info
		--Track Image must be 1280 x 720
		--Start Position on the Image x,y from Top Left
		Start = { 204, 347 },

		--How many pixels per meter ( Pixels / Length )
		--Measure a long straight and then manipulate from there
		Scale = 20 / 32,
		Layout = { STRAIGHT, },
		LayoutInfo = { 1609.3, },
		CornerRadius = { 0, },
		Slope = { 0, },
		Sportiness = { 0, },
		Camber = { 0, },
		Split1 = 402.3,
		Split2 = 1000,
}

PNG file is 1280*720 pixels and car is positioned correctly on it in Automation as seen on this screen :

Thanks !

EDIT
The track is working. The combination of this track (car was working as it was on other custom tracks, just some) and this car configuration that would block track simulation. Once I changed suspensions from solid axle coil/double wishbone to pushrod/pushrod and decreased suspension height, the simulation was working.
The SAC/DW + max suspensions height configuration was used because it is, according to “Power vs. Traction” graph, what gives the best acceleration (g). That in BeamNG results in the front lifting during acceleration (from gear 1 to 4 or 5). The car would go in barrel rolls if throttle is kept maxed.
So bonus question : Is that the reason for the simulation not starting in Automation ??

Thanks !


#2

I’ve tried, and nope.


#3

Regarding the bonus question: I think we addressed that issue before, indeed we did have issues with the simulation breaking when the car’s front lifts, but I thought we lower throttle at that point nowadays. When you lower power to a degree that it can’t do it, does the track + car combo work then?


#4

Hi Killrob,

First, thank you for all your videos and tutorials ! Very helpful.

I’ve tried several configurations since then. Let me make you an abstract of some sort.

V1 (first culprit) : V12 12.2L 2716HP with turbo, suspensions are solid axle coil as front and double wishbone at the rear set at max height (451.7 mm). Total weight is 1681Kg with 68.9% at rear. Lifting is crazy and very hard to control in BeamNG, track simulation does not work.

V2 : same engine, no front weight added (70.3% rear weight, 1604 Kg), suspensions swapped to pushrod on both ends and minimal height. That is giving slight lift of the front wheels, but no need to release throttle to control in BeanNG. The track simulation is not working.

V3 : same as V1, front wheels width from 90 to 95 and track simulation is working, and is not maxing throttle before 4th gear. This has no effect on the behavior of the car in BeamNG.

N.B. : The only (red) warning the game is giving me on those versions is “The car has strong understeer” which is kind of the point anyway. So “Tires overloaded” is not the culprit in V1 and V2.

And fun fact : when the car is loaded in BeamNG, rear brake fade instantly :