Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Tutorial UE4 modding


#1

Hi there,

is there some kind of tutorial for the ue4 editor? Which type of files do I need to implement the mods to the game?

I see, that there are a lot of *.uasset und *.uexp files. When I use the UE4 editor I can convert my stuff to *.umap. I don’t know how to get uasset and uexp files.

Maybe someone can halp here.


#2

Not much documentation yet, what we do have so far is here - https://automation.gamepedia.com/Modding


#3

May I report that in the current tutorials many images are also missing or very difficult to read due to bad resolution.


#4

Yeah, they’re migrating the wiki to a new server, and it seems to have broken some stuff. Will fix once they finish the server migration.


#5

How do you get your own mods in game? I tried the entire fixture tutorial for creating a badge using a conform mesh only, but even after creating the tumbnails I do not see it ingame? Do I need to export the files and add them to my automation mods folder of something?


#6

Wait a sec… even if you open the generate thumbnail level and assign the blueprint and hit export preview it doesn’t make a separate folder for that? If all of that is done and you’ve ticked off all the steps then hit share/cook or whatever button it is and it’ll output to a folder which you then need to copy into C:\Program Files (x86)\Steam\steamapps\common\Automation\WindowsNoEditor\AutomationGame\Plugins


#7

Currently, if I try to cook/share something the compiler cannot process it. It give an error message.

The compiler gives the following error message:

UATHelper: Packaging Hollandia (Windows): Cook: LogInit: Display: CookResults: Error: Couldn’t save package, filename is too long: D:/Program Files (x86)/Steam/steamapps/common/Automation_SDK/AutomationGame/Saved/CookMod/AutomationGame/Plugins/Hollandia/Content/Fixtures/Badges/Hollandia_Badge/Thumbnails/Hollandia_Badge_chrome/Hollandia_Badge_chrome_Preview.u
asset

EDIT: I made the name a bit shorter, at least it compiles now. Strange that the length of a name can be an issue still.


#8

OK, I managed to get my badge to work. First time I created a fixture mod in Automation, I’m so happy with it. Now I’m going to try to improve on it, at least I now know how to do stuff.


#9

I have some issues when trying to create a custom badge. I managed to create a .tga for texture including alpha channel with GIMP and a normal map, but I fail at the first step in “Importing to UE4” - “Create a new Badge Mod” (https://automation.gamepedia.com/Badge_Fixture_Mods#Importing_to_UE4):

There’s an error message when the Editor wants to copy the plugin template:

It seems like the file it wants to copy is missing:

@Daffyflyer Can you confirm that there’s something missing or is it an error on my side? Thanks in advance!


#10

Sounds like a @zeussy issue I think?


#11

Yeah, I will have to look into that.

All the Stuff you need should be in the ExamplesBadges Plugin that you should find under the content browser.

You should be able to make a New Empty Plugin/Mod and then just copy the content from ExampleBadges into it, as a work around for now.


#12

Anyone have any idea what this error means? It happens sometimes when I try to mirror a skinned body:
–Runtime error: Mesh map vertex out of range: < 1 or > 4116: 4117


#13

I get it often (Less so with 2018 than 2013) and I don’t know why it happens. However to get round it I save my work, close 3dsmax and Reopen. As long as mirroring is the 1st thing I do it works.

See https://automation.gamepedia.com/Car_Body_Mods#FAQ


#14

Yes, I’m puzzled every time I stumble on this problem but I usually solve this with Long Path Tool.


#15

image

UE4 Editor doesn’t work. Can someone please help me?

Edit: UE4 Version 4.17.2


#16

Do you have the right version of the UE4 engine? 4.17.2 is what’s currently required.

Edit: Just saw the edit… Hmm, no idea then.


#17

I’ve been having the same problem for awhile. Might just have to wait until the game is more developed I guess.


#18

I think this is one for @zeussy to look at when he’s back from dying of the plague


Help Opening project files in UE4 editor (solved!)
#19

Hi I am also having an issue with opining the game modding tools in ue4.17.2. When I try to open it it Says the project was made in a different version. When I try to convert it it fails due to missing files. If you copy the source folder from the unreal engine install folder it opens, but it gives errors when loading assets or cooking the mod and the exported mod never shows up in game.


#20

You need to skip conversion