Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

UE4 crashes


#1

so hello. let me discribe whats happening. i play this game since a while now but the UE4 version isnt starting. if i start this version the loadingscreen appears and after 10 seconds the window closes and a crash report window opens

here are the crash logs:

Fatal error: [File:D:\workspace\UE4-Camso\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 3013]
Missing Dependency, request for Interior_Engine_80s_Small_ControlRoom_WallToOffice_LOW_Blueprint_C but it hasn’t been created yet.

KERNELBASE.dll!0x0000000047EC4008
AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenIndexToObject()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenCreateExport()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::ProcessImportsAndExports_Event()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::Event_ProcessImportsAndExports()
AutomationGame-Win64-Shipping.exe!FObjectAndNameAsStringProxyArchive::operator<<()
AutomationGame-Win64-Shipping.exe!FAsyncLoadEventQueue::PopAndExecute()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::ProcessAsyncLoading()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::GuardedRun()
KERNEL32.DLL!0x0000000049761FE4
ntdll.dll!0x000000004C31EFC1
ntdll.dll!0x000000004C31EFC1

Crash in runnable thread FAsyncLoadingThread

Fatal error: [File:D:\workspace\UE4-Camso\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 3013]
Missing Dependency, request for Interior_Engine_80s_Small_ControlRoom_WallToOffice_LOW_Blueprint_C but it hasn’t been created yet.

KERNELBASE.dll!0x0000000047EC4008
AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenIndexToObject()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenCreateExport()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::ProcessImportsAndExports_Event()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::Event_ProcessImportsAndExports()
AutomationGame-Win64-Shipping.exe!FObjectAndNameAsStringProxyArchive::operator<<()
AutomationGame-Win64-Shipping.exe!FAsyncLoadEventQueue::PopAndExecute()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::ProcessAsyncLoading()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::GuardedRun()
KERNEL32.DLL!0x0000000049761FE4
ntdll.dll!0x000000004C31EFC1
ntdll.dll!0x000000004C31EFC1

Crash in runnable thread FAsyncLoadingThread

Fatal error: [File:D:\workspace\UE4-Camso\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 3013]
Missing Dependency, request for Interior_Engine_80s_Small_ControlRoom_WallToOffice_LOW_Blueprint_C but it hasn’t been created yet.

KERNELBASE.dll!0x0000000047EC4008
AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenIndexToObject()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenCreateExport()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::ProcessImportsAndExports_Event()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::Event_ProcessImportsAndExports()
AutomationGame-Win64-Shipping.exe!FObjectAndNameAsStringProxyArchive::operator<<()
AutomationGame-Win64-Shipping.exe!FAsyncLoadEventQueue::PopAndExecute()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::ProcessAsyncLoading()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::GuardedRun()
KERNEL32.DLL!0x0000000049761FE4
ntdll.dll!0x000000004C31EFC1
ntdll.dll!0x000000004C31EFC1

Crash in runnable thread FAsyncLoadingThread

Fatal error: [File:D:\workspace\UE4-Camso\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 3013]
Missing Dependency, request for Interior_Engine_80s_Small_ControlRoom_WallToOffice_LOW_Blueprint_C but it hasn’t been created yet.

KERNELBASE.dll!0x0000000047EC4008
AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenIndexToObject()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::EventDrivenCreateExport()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::ProcessImportsAndExports_Event()
AutomationGame-Win64-Shipping.exe!FAsyncPackage::Event_ProcessImportsAndExports()
AutomationGame-Win64-Shipping.exe!FObjectAndNameAsStringProxyArchive::operator<<()
AutomationGame-Win64-Shipping.exe!FAsyncLoadEventQueue::PopAndExecute()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::ProcessAsyncLoading()
AutomationGame-Win64-Shipping.exe!FAsyncLoadingThread::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::Run()
AutomationGame-Win64-Shipping.exe!FRunnableThreadWin::GuardedRun()
KERNEL32.DLL!0x0000000049761FE4
ntdll.dll!0x000000004C31EFC1
ntdll.dll!0x000000004C31EFC1

Crash in runnable thread FAsyncLoadingThread

I did everything i found in the troubleshooting FAQ but it sadly didn´t change anything.i´ve also tried every lauch option possible. My hardware is also good enough to handle this game. i don´t really know what to do at this point. would be really glad to hear any reply.


#2

That does look like there is a file missing or broken, are you sure you have verified your game files?


#3

This might also be a mods issue. Although the file it is whinging about isn’t mod related. Maybe a mod is upsetting the ASyncLoadingThread and that is just the asset it whinges about? Do you have any mods installed?

Could you unsubscribe to them and see if that fixes it?


#4

Firstly thanks for the replies. I’m glad you’ve answered. Well i can’t even count how often I’ve verified the game data. I verified it reinstalled it verified it again… Etc. but it’s not changing anything. I’ve also unsubscribed to every single mod but that also didnt change anything. Any more ideas what the issue could be :confused:


#5

Ok, goto %LocalAppData%\AutomationGame (copy and paste that into an explorer address bar)

Delete all the contents of that folder (Mainly the Saved folder). This is various UE4 settings etc (doesn’t contain any of your car saves). See if that fixes it.

The other possiblity that i hate to say is, the one thing Verifying files doesn’t do, nor does “uninstalling in steam”. Is remove files that should have been removed during an update, but weren’t.

So there could be an errant file, that is being loaded that shouldn’t be. And Steam itself doesn’t have any facilities to deal with it.

Right Click properties of Automation In Steam. Properties. Local Files, Browse Local Files. Delete the WindowsNoEditor folder. Then do a Verify Integretity and get it to bring down the UE4 version again.


#6

thanks for the reply. So i recently tried both methods out but there is absolutly no change. sadly the same issues. Any other thoughts what the issue could be?


#7

I’m having this same issue with my copy of this game so any help with this would be greatly appreciated


#8

Could you just check to see if you have Interior_Engine_80s_Small_ControlRoom_WallToOffice_LOW_Blueprint.uasset and .uexp in

WindowsNoEditor\AutomationGame\Content\Environments\BuildingInteriors\Assets\

To get to the WindowsNoEditor folder: Right Click properties of Automation In Steam. Properties. Local Files, Browse Local Files.

If it is there, I will open a ticket up with Epic. As this is beyond my ability to fix.


#9

Yes i have both of those files is in the assets folder


#10

Thanks, I’ll open up an issue with Epic and see what ideas they may have.


#12

Yeah i have both files in there too. Sorry i don’t really understand what you mean by opening up a ticket with epic.


#13

Epic Games is the maker of the Unreal Engine 4 (UE4) which we use for Automation. :slight_smile:


#14

Oh yeah haha forgot… Thanks for the info. I’ll stay tuned and hope the best for my copy of automation haha


#15

Still no reply from Epic Games. They have just realeased 4.20 engine update, so they are a bit snowed under with issues atm.


#16

No problem. I can wait. I already thank you for all your effort


#17

Hello. Are there some news?


#18

There is news but not good news. Epic’s reply was basically 4.17 is old now. You should update.

One of the Plugins we use for all our dynamic mesh stuff has a fundamental issue with 4.20 and waiting for a fix, or I find the time to dive in and fix it myself. We are probably looking to do a 4.20 release with the Campaign update.