Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

UE4 Exporter Update Discussion / Bugs


#1

This is now the official thread on these Discourse forums for posting issues related to the latest Exporter Update release version. Please post about any Automation and Exporter related issues.

If you have cars that do not work in BeamNG, please attach the .car file to your post here and give a reasonably detailed description of what is happening. You can get the .car file by saving the car for sharing from the Car Manager, there is that little disk icon to do so.

Thank you!


#2

#3

One word:

AESTHETICS

In all of Seriousness,I hope that the Unreal port to be a really good game.I have question though,will the change to UE4 be permanent or will the current engine be used in the future?


#4
  1. this thread is mostly about bugsand the discussion of bugs and not inputs/recommendation.
  2. you mean the current kee engine. afaik it will be left behind completely.

okay. so the update hasn’t been done yet right?

but i can’t open automation anymore right now. though i dunno if it has anything to do with UE4.

these 2 warnings suddenly popped up. never before had it done so.

what happened

and then after i click ‘OK’

then the usual launcher pops up. i click ‘play game’ and it just closes after opening an automation window for a few seconds.


what i have tried :
both open beta or not doesn’t make a difference.
tried windowed mode, still the same
the setting said i’m on 1366x768p resolution. but it shows that 720p warning anyway.
tried deleting the automation folder. nah. same result

was going to try changing resolution… but it’s gone


what i think may or may not have caused it :

there’s a windows update in the middle of the night when i was sleeping.


i’d recommend everyone who hasn’t got their win10 update, don’t update yet. i dunno what the impact is. but i think it’s somehow related. just take the safe route for now. it is not confirmed yet.


#5

I have a question about paint before we start the Open Beta: will we have selectable flake color with strength?, as I saw it on earlier UE4 Dev Update, as well as earlier paint color testing video in the Automation Facebook page.


#6

Nah, no flake colour, it just didn’t work well.


#7

The new beta just finished downloading and the first thing I see is a warning from my AV.


This version loaded for me super quick, about 3 seconds.


#9

Can anyone help me?


#10

Is 50 minutes long enough for “half an eternity” to load the game? It’s installed on an SSD. At the start it used about 270 MB of RAM, after a few minutes reduced to 110 MB and probably all the time uses up to 4% of the CPU. The window is still just all black.


#11

ive noctied alot of crashes with certian things like when i hot 4x4 it crashes or if i put the badge on the car it crashes its beta tho so im not mad just abit dissapointed i cant play very well without crashes and have to wait 10 mins to load the game aslo when i hit new model it tends to hang for a good 2 mins


#12

I’ve got this too.

Snooped around and discovered while the Global Shader Cache file for Shader Model 5.0 (DX11) is present (GlobalShaderCache-PCD3D_SM5.bin), it’s DX10 compatible Shader Model 4.0 counterpart is not as the engine error so kindly points out.

So basically if your GPU does not support DX11 it won’t run because this required file for DX10 compatibility isn’t present in this build.

However in theory the devs will giveth unto us the Shader Model 4.0 Global Shader Cache file in the next build so that we Toaster-bound DX10 plebs may enjoy the CILF (Code I’d like to F***) Unreal Engine 4.

By the way I’m talking out of my ass, correct me If i’m wrong devs.


#13

Unfortunately, the game crashes every time I try to revise a certain car. However, I don’t know yet whether it’s only an issue with this specific car or a general problem. It’s quite annoying though.:weary:


#14

Thanks for the reply, but the problem is that I have DX11 on my computer :grimacing:


#15

Sure, but does your Graphics Processing Unit (GPU) Itself actually support it?

For example I have it installed too via Windows 7, however my GMA 4500m GPU only supports up to DX10.

If my previous post hypothesis is correct, for the time being only all of the following will be able to play the Unreal 4 version until the devs add DX10 compatibility.

All Nvidia Geforce cards 400 series and newer
All ATI Radeon cards HD 5000 series and newer
All Intel HD Graphics paired with Ivy Bridge (HD 4000) and newer

When the devs decide to add DX10 compatibility, the compatible list would be revised to this

All Nvidia Geforce cards 8000 series and newer
All ATI Radeon cards HD 2000 series and newer
All Intel GMA graphics GPUs X3500/X3100 and newer


#16

The “Oldest” machine i managed to play it on was with a i5-3320m and a HD4000 Unit.

Please post HW-Specs if you encounter these problems!

Known to work configurations: i5-3320M, HD4000 Athlon X4 860k, R7 260X Athlons X8-7650k, R7 250 (iGPU) i7-6700HQ, GTX960M i7-6700k, GTX1080

#17

Can tally my machine in with an inability to start.

Intel Xeon E5645, nVidia GTX 275, running Windows 7 x64 SP1.

I know the card is DX10 only.

I get the same message as described above, that there’s a missing global shader cache file.


#18

Just downloaded the open beta and tried it. I had crashes revising a car, editing engine, editing paint, adding engines to a car. This is the error dialog that I got when the game crashed

Is the file directory mentioned in error dialog location of the crash log? I can provide it if it is needed.

Also in the Unreal version, molding body shapes and fixtures is hard; it resizes too fast, and it won’t resize on certain angle unlike in the Key engine.

It’s kind of unplayable right now, but I’ll be patient for future bug fixes and features :wink:


#19

Please fill in stuff. Questions via PM. I will gather up data in a nice and clean fashion :slight_smile:

@Madrias As it currently seems the game will only run with DX11/SM5 cards or above. Maybe the devs will do a SM4 compatability fix for it - UE4 does support SM4/D3D10 cards if i remember it correctly. Its just a matter of compiling it and adding the libraries, which might lead to extra work.

Don’t forget to file bug reports with ways to produce the bug. (IF your game starts - and if its game breaking - small stuff is not too important ATM!) - If your game does not start, please add your PC Config, OS etc. here so we can figure something out.


#20

Don’t speed up the playback speed in the test track really rapidly like I did

First you’ll get some really big RPM number like this:

And then Automation borks and does this:

You’ll also get some sort of weird engine noise, either the engine at a certain RPM constantly or barely anything.


#21

As I wrote above, it gets stuck at a black window doing seemingly nothing (very minimal RAM and processor usage, when I tried to run it again the RAM usage dropped to just a few MB) for at least 50 minutes. My spec:

Athlon II X3 440
Radeon R9 380
8 GB RAM
Windows 10 Creators Update (compilation number 15063.296, 64 bit of course)
both system and the game installed on the SSD