Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

UE4 Exporter Update Discussion / Bugs


#656

In one of my groups on Facebook, a guy on there, made a program to see where the bottleneck was in a computer system with a program/game. When I use it with Automation it tells me that the bottleneck is my graphics card. I constantly get around 55-60 FPS and the same with Vsync turned off. Other more intense UE4 games usually get 65-80 ave. FPS on my system with less GPU strain. Has there been any optimizations to GPU performance yet, or is that something that will be happening later down the line, or am I just expecting something that isn’t going to happen?


#657

I would not expect any major improvements to framerates at this point. We did do a lot of optimization work after the first public UE4 version came out, that improved performance significantly. Since then we’ve not looking into it further but may for future updates if necessary.


#658

You know, I don’t think I’ve mentioned yet just how much I love the fact that Longitudinal FWD can actually take some decent engines now. Was planning on a car company in UE4 being based on inline 6 engines and RWD, but… It’s actually feasible to use I6 engines and FWD. (For the record, my most common engine size in the I6 range is 3 to 4 liters of displacement, so I’m not being exactly stupid with engine sizes for once.)

I’ve been having a lot of fun with that, and I’ll be revising some company lore for UE4 to have L-FWD and I6 together, a match made in heaven. Beautifully smooth engines, and easy-to-drive handling.


#659

Volvo! :smiley: And Daewoo. Though they used transverse.


#660

I still got the bug that the game crashes when cloning a trim and create a new engine family in that trim.

Explanation:
Whenever I have created a car trim, I often want to make a more/less powerfull variant of that trim with a totally different engine family. So i go to the car list, press clone car trim on an already finished trim, and revise the just created trim copy. In that trim copy I go to the engine select screen. In this engine select screen i select “create new family”. From that point on, when designing the new engine family and car trim, the game will always crash. This can be a few seconds after creating a new engine family up to a full 20 minutes after creating the engine family. The thing is; it will always happen and it made me affraid of cloning a car trim and adding a new engine to this trim. The worst part is that half of the time this crash results in a game freeze which I can’t minimize and will result in having to reboot the pc or sign out and in to Windows. This also means that half of the crashes I can’t send a crash report. I already tried reinstalling the game and playing without user made mods. I already send alot of the crash reports to you guys with the “Radializer” username if you want more info. Other then this bug, I don’t really have any complaints. Keep up the good work.


#661

@Radializer That doesn’t sound like there is any direct connection between the engine family creation and the crash though, unless it would always happen at the same time after the same action. I’ll check it out to see if I can get that issue on my system too. Thanks for the exact description of the steps involved.


#662

I’ve been having the same bug as @Radializer since UE4 came out. It always seems to happen the same way but never the same time. I’ve subbmitted several bug reports and I got an email from “Caswel Parker” explaining that it was a bug in the Unreal Engine itself.


#663

Yes, it probably is the garbage collector bug, which is a real pain in the ass because it’s so deep in UE4.


#664

No problem, I really appreciate to be able to help you guys.
Additional info:
-The game seems to work fine when I restart it and reopen the trim with the newly made engine. I can just continue designing the engine/trim without any notable problems.
-The game freezing while this bug occurs, and not being able to minimize it and forcing me to sign out and in of Windows and also obstructing me from sending a crash report, seems to happen more and more often.
-In very rare cases the game will crash early on in the design proces of a new model (fixtures placement). But in this case there is also a very big chance on freezing the game with no crash report as a result.
-The crashes always occur at a moment that I am not pressing any key or button (they feel very random and out of nowhere).

At first I did not really bother much attention to this bug(s), but as time progresses the pattern between the crashes became more and more clear. I am an engine guy so designing multiple engine families on a single car model is a ‘must’ for me. Lately I see myself more and more often skipping playing automation because of this bug. So in my case, regarding the impact it has on my gameplay experience, I would call it a major bug.

If there is anything I can do to help you guys fix this, please let me know!


#665

The only thing that seems a little odd in your case is that the game freezes instead of just crashing, which it usually does in the garbage collection bug. Have you tried to update your graphics drivers any time recently? If not, it might be a good idea to get the latest, as we switched the game engine recently to UE4.17.2


#666

Ok, I updated my video drivers to the latest as you suggested. When I restarted the game I copied a car trim and created a new engine family. About 10 secs in the engine designer (engine type tab) the game crashed and I reported the error report again under the username Radializer. It seems that updating the video drivers did not have any effect on this specific crash because I am able to recreate this specific crash within 1 to 2 minutes in the game.

pc specs:

  • Windows 10 64-bit
  • Nvidia GTX 980
  • Intel i7-6700 3.4Ghz
  • 16GB ddr4 RAM

#667

Bug? I have created custom paints that contain base/flake or base/pearl. When I go to Photo Scene and Photo Studio, my vehicles appear black in color. I have also made colors with only a base color and no flake nor pearl, and when shown in the Photo Studio, my vehicles appear the proper color. Any ideas? Thank, in advance, for your interest and assistance.
Carl


#668

Thanks @Radializer ,

You have fallen to the issue that affects a few people a lot more than others, and is one we cannot replicate reliable in the office.

I have made a special Beta Branch, Right Click -> Properties on Automation in Steam. Betas -> Select crash_helper.

It is no different to the current public release, apart from has a very specific set of code to try and log and catch more details about the crash. If you can play with that build instead, and submit the crash reports from it, that would be fantastic!

If you could send me a message when you have sent a report that would be great. It may take a few goes, as the issue is random, and my error catching only catches one case (the most common one). And The error catching code isn’t well tested, as we cannot test it here.


#669

@zeussy As you requested, I just send you a new crash report with the extended crash_helper version. It was fairly easy to make it crash again as it crashed within 20 secs in the engine designer after cloning a car trim and create a new engine family. I picked a different car model then last time to make sure it had nothing to do with the car model/trim. Also I choose an other engine type to exclude the engine type from being the cause of this problem.


#670

Thanks @Radializer, that report contained the info I wanted, but then Visual Studio/Windbg doesn’t want to play nicely. I needed to resolve the program addresses given in the callstack to function calls, but alas I am not quite sure why windbg isn’t taking my commands. And Visual Studio is convinced that the exe I am supplying for the minidump doesn’t match. :frowning:

I have just pushed up another build that includes the Program Debug Database, so it will link the callstack dump links up to the function names automatically. And will give me what I need. So if you can give it ago again that would be fantastic.

The crash is in the garbage collection of clean up UI objects, and only occasionally happens. For some people it is really common. For others it basically never happens. As the garbage collector only occasional does work, that is why the crash is some x seconds from the last action.

Just to reiterate your steps, can you clarify them:

  • Make a new car & Engine from start to finish
  • Press the Car button to the left of the Model Name & Year
  • Selecting the Trim you want to clone
  • Pressing Clone button
  • Revise/Open the Cloned Trim
  • Click the Engine Button to the left of Engine Family/Year
  • New Engine Family
  • Wait for crash?

Is there any changes to which panel or designer you are at during this? Or is your flow different? As these steps do not produce the crash for me. My next step would be to push a build that logs every UI interaction so I can replicate the play by play myself.

Thanks for the help so far, hopefully we can get to the bottom of this.


#671

I am at a trip for work so it will take me at least 2 more days to give you a usefull reply. Sorry for the inconvenience.


#672

Ok so I just managed to crash the game again and upload a crash report. This time it did not immediately crash on the first car I copied and gave a new engine. But I switched to another one soon enough and I managed to crash the game within 5 minutes.

There are two ways to crash the game (almost similar to eachother). I will try to clarify these two ways in the follow lists:
1:

  • Make a new car & Engine from start to finish
  • Press the Car button to the left of the Model Name & Year
  • Selecting the Trim I want to clone
  • Pressing Clone button
  • Revise/Open the Cloned Trim
  • Click the Engine Button to the left of Engine Family/Year
  • New Engine Family
  • Now I automaticaly enter the trim results screen from the copied trim, so I have to go back to the first engine design step in the bottom of the screen (designer flow) to design the new engine.
  • Proceed through the engine designer steps and a crash will (very soon) happen.

2:

  • In the main menu go to sandbox
  • Selecting the Trim I want to clone and that I designed earlier (can be of any moment in history)
  • Pressing Clone button
  • Revise/Open the Cloned Trim
  • Click the Engine Button to the left of Engine Family/Year
  • New Engine Family
  • Now I automaticaly enter the trim results screen from the copied trim, so I have to go back to the first engine design step in the bottom of the screen to design the new engine.
  • Proceed through the engine designer steps and a crash will (very soon) happen.

As I said earlier in this post. This time it wouldn’t crash immediately in the design of the new engine. But it would have surely crashed later on when designing the trim. To reduce the time needed to crash, I just abandoned the selected one and created another copy with another new engine.


#673

40s Sedan (2.1m) has issues with all rear suspension poking out of the side of the car.

Pickup and van variants are fine as the body goes all the way out to the outer edge of the wheel arch.


#674

Not any kind of bug, just a thought because I’m a bit thick. With the brake bias slider, would it not be a touch more helpful to have the front and rear percentages where they adjust (“Rear” at the top, “Front” at the bottom)? I am only saying this because I keep getting it backwards when I make adjustments (you think I would have learned by now, but, no).


#675

Erm, so I’m having a strange issue never faced before.

The car I’m making is a F-AWD hatchback, longitudinal placement, with some race oriented choices, not that they matter too much. Model year is 1982 and this specific trim is a 1984. Engine is a laggy as fuck 1.6 turbo (372hp, 45 reliability) which won’t be drivable, no surprise there, but when I finish up and go to the next tab, this happens:


yes, it also is at 50:50 power distribution. I can’t understand for the life of me what the issue is, the brakes are fine, the suspension is at the normal preset and the aero is untouched. Plus for a 1000kg 370hp AWD hatch, those times are not right at all.

If I set it to the final ratio just before it goes to -1, on the test track it always starts in 5th gear from the start line and only shifts into lower gears when it slows down for a corner, some properly weird ass stuff
bug

EDIT: Yeah, no matter what I tune it to, it shifts immediately into 5th.