Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

VMO's stuff (MODDING AGAIN!)


#261

The Coupe isn’t finished: is the 3d file.

I need a user that can put the bones (I fixed the body issues).


#262

Someone please help him because I want this so badly!

Good work by the way on the model! :slight_smile:


#263

Is anybody else having difficulty getting some of the mods to install? I’m trying to get the game to detect the diffuser and canards, which are clearly in my meshes folders, but they refuse to show up!


#264

I dont had issues.


#265

Okay, in that case, I think I’ll need your help. All your mods, as far as I can tell, work fine on my computer (after it finally updates, I did a reinstall and everything). Except for the diffuser and canard I mentioned.

With which item on the workshop were they bundled? What was the file structure? I can see them in my folders but I can’t work out why they won’t load for me.

EDIT: I have reinstalled and reverified all the files and I can’t find the diffuser or the canards in the files downloaded from the workshop! So yeah, where on the workshop were they? Maybe I haven’t even downloaded them yet.


#266

Excited for the luxury coupe body! I can’t shake the fact that the door is too short, and the window where the other doors used to be is the same size. :neutral_face: Did it get changed, or is there just going to be a morph there?


#267

Thanks to Maffc for the bones and some improvements :wink:

I exported the model, but I had the “classic” problem: a big and ugly pink box over the car.

How can I fix this issue?

Coming soon, I will release the coupé to steam.


#268

[quote=“strop”]Okay, in that case, I think I’ll need your help. All your mods, as far as I can tell, work fine on my computer (after it finally updates, I did a reinstall and everything). Except for the diffuser and canard I mentioned.

With which item on the workshop were they bundled? What was the file structure? I can see them in my folders but I can’t work out why they won’t load for me.

EDIT: I have reinstalled and reverified all the files and I can’t find the diffuser or the canards in the files downloaded from the workshop! So yeah, where on the workshop were they? Maybe I haven’t even downloaded them yet.[/quote]

The canards and diffusers are included in the VMO Modpack 1 v1.1. Sorry for the delay.


#269

[quote=“vmo”]Thanks to Maffc for the bones and some improvements :wink:

I exported the model, but I had the “classic” problem: a big and ugly pink box over the car.

How can I fix this issue?

Coming soon, I will release the coupé to steam.[/quote]

The game maps it’s materials across to those of the model’s, unfortunately 3ds Max likes to shuffle these so the mappings are not consistent. To get round this the Devs have put a section in the LUA file that looks similar to this

	Materials = {
		"ECS_BODY", --Middle
		"ECS_BODY", --Front
		"ECS_BODY",  --Rear
		"ECS_PLASTIC",
		"ECS_CHROME",
		"ECS_BODY", --Other body Paint
		"ECS_GLASS",
		"ECS_SEAM", --Middle
		"ECS_SEAM", --Rear Seam
		"ECS_CARGO",
		"ECS_CARGO_REAR",
		"ECS_BOTTOM_BOX",
		"ECS_TOP_BOX",
		"ECS_SEAM", --Front
		"ECS_TRANSPARENT",
	},

This tells automation that for this model the 1st material in the file is Body Paint, as is the 2nd and 3rd, the 4th is “Plastic”, etc. Bright Pink boxes (or other body parts) are normally an indication that a material mapping is not found. (In your case I suspect you are missing entries for the top and bottom body boxes - see above)

You need to amend the LUA file so that the mappings match. The “easiest way” to do this is this.

  • set your 1st material to “ESC_NOTFOUND” (this will force the material to be pink)
  • save the LUA
  • load your model in Automation and look for the new pink bit
  • change the “NOTFOUND” entry in the LUA to be the correct value
  • repeat with the next material in the list.

The above LUA extract has all the current material mapping values for bodies. I also add comments to show which section of body or seam that material belongs to, we will return to that later. In between each cycle all you need is change the year in car designer and re-click on the body. The new mappings will be applied and the pink bit should move.
Once all the mappings are correct we need to move further down the LUA to this section

ProjectionMaterials = {
		Front = 2,
		Middle = 1,
		Rear = 3
	},

This tells Automation which bit of body paint is what section of the car, this is why we make comments in the main list. Count down the list till you find the front body paint and put that number into the Front = section, repeat for Middle and Rear. Other body paint does not need to be assigned here.

Repate the process again for the following section of the LUA file, only this time we are looking for Seam materials

   ProjectionSeamMaterials = {
		Front = 14,
		Middle = 8,
		Rear = 9
	},

Once this is done the correct materials will be assigned within game, fixutres can be added to the correct areas of the car and, providing the UV mapping is OK, no unexpected holes should appear.


#270

Ok. I understand the 50%, but I will try. Thanks.

EDIT: I found the missing material, and I solved the issue.

The car had some bugs, that I will solve after the first release of body into Steam Workshop:
-In the rear window, between the chrome trim and body, is missing a thin body part (like the car doesn’t had the chrome glass trim).
-In the rear modified part, between the rear wing and the “edited door”, the texture looks strange, because i doesn’t put the same paint type in the two surfaces.


#271

Here is the beta1.

vmo_sedan_coupe_10s_BETA1.zip (982 KB)
I changed the bones names, but I doesn’t move ingame.

Here is the download. Extract into GameData.


#272

Loving it :smiley: Looking forward to working morphs! I’d suggest the door going back a bit further though. And might I also add that this would be a load of fun with highly adjustable morphs?

EDIT: Made something to celebrate.



#273

When the poll finished, I’d say that I doesnt make the GT-R R35 because are difficult.

Ok. Since september, I was making the body in secret, and here a screenshot (only I had problems with the pillars).

I tessellate the model 1 step (and, obviously, I didn’t merged with the “raw” mesh) to smooth the body.



#274

seems legit


#275

New capture:



#276

About the non-xf coupé body, I had the bones named as the video says, and edited into the bones.LUA, but it doesn’t move ingame :frowning:

EDIT: I finished the GT-R r35 body.


#277

Make sure the values are properly assigned in the .lua file and that the names match the names of the bones in your model. Some of the axis names in there aren’t exactly right, so you should try every one of them out to make sure they work properly. As long as you have the skin made like in the tutorial videos, the rest of the work is the values in the .lua.


#278

News about the GT-R R35:



#279

Ingame:



#280

guess there is still some work left to do