Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

VMO's stuff (Now attempting to port to UE4!)


Nice one, now what did i name that 3.8l tt v6 i made.... :smiling_imp:


Just LS Swap it


Oh jesus, I want that. More 00s coupes!


How can I center the wheelbase to match ingame?

Because in the game, only one wheel are inside the wheel arch, and other had offset.


Sounds like your model does not quite have the wheelbase you thought it had.
Double check that on the model, you could use the measuring tool for a quick check.
When you amend the wheelbase value in the lua they may still not be aligned, but both wheels should at least be out of alignment by the same amount in the same direction.
Then what I do is nudge my max model along the horizontal axis and re-export till they line up.


I had issues with the lua files.

What is any settings of the lua body files?


The "RearRatio" value in the .lua file with move the frame forward or backwards to line up with the body, so play around with values for that and for the wheelbase and things should line up. MorphWidth is then for how wide the frame is, so make it narrow enough that you can get decently wide wheels without morphing, but wide enough to fit decently large engines. MorphRideHeight is for the height of the wheels, but if the body is too high on the frame, you'll need to lower it in 3ds Max (having it about 5-10 cm below 0 on the Z axis seems to work best). Then MorphNose and MorphTail just stretch the end of the frame to better fit the body, especially useful for maximising space in the engine bay.




New issues with 3ds max: when I'm making the bones, I selected the root bone (or bone root), edit envelopes and select vertices, select all body and set to 1 the abs, and next the front flare: I select the frontflare bone, all is gray, I selected only the exterior of wheel arch, but when I set the abs value with the mouse wheel, the arch doesn't modify.

I restarted the computer, but the problem persists.


If there's only one bone to certain vertices, set it at 0.5 (unless you'd like a lower value), but that's the maximum one you should use. When out of the "edit envelope" section, select the box associated with that bone, and move it back and forth. Does the bone move when you move it?

Also, a recommendation when setting the bones, if you move the box out before selecting the vertices, move it by an easy to remember value (20 cm, -15 cm, etc) so that when you finish with it, you just need to type in the opposite of that value to have it back exactly where it was so that you can easily export without the bones being in a different place then the original model. I made that mistake with my first model, and that avoids that issue.


have you tried to remove zero weights? (button found at the bottom of the Advanced Parameters section)

sometimes I find it's a bit stubborn, so I use the weights table and manually type in the value for the selected vertex / bone.
(you can change the default weight table view to be select vertices instead of all of them - drop down menu in the bottom left)


I solved these step, thanks!

I exported the body (I selected the GT-r body with the selector), and I named the bones.lua, but ingame, I can't morph the car.

In 3ds max I can move the bones, and the body morphs.

Yep. I solved.


I finished the bones in 3ds max, I changed and I set the name and values in bones.lua, all car lua settings completed, but ingame, I can't move or select any morphing zone, only appears the body touching shadow in all car, instead the morph parts.

Only I need to solve this (Anyone can help me, please?) to release in Steam.


I've noticed the Lua is case sensitive when it comes to bone names.
Double check they match exactly between lua and max


I checked this and is ok.

If i sent to you the files is better?


I won't be able to investigate for a few hours, I'm away from my pc using a phone, but happy to have a look if you want to send me them.


You can send them to me. I'll investigate happily.


Ok. I'm uploading the files, and I will sent to both.


Another thing about that bones is that you can't have spaces in the names. The 3ds Max names need to be all one word, with the names in the .lua matching.


But the root bone or bone root have spaces according with the tutorial.