Exporting to Beam engines are locking up

I have tried a dozen different engines. All below 1400CC (if that would cause anything). I had a few engines work for a while, but then do the same thing. Most of the time this happens within a few seconds of pulling out. Am I missing something? I have about 100 exported cars over the past year and this is the first time this has occurred.

Did the engine hit the rev limiter? There is an issue we’re aware of with engines locking up when they destroy themselves for not good reason. That is more of a BeamNG issue than one on our end though, we’re in contact with the BeamNG team to try and resolve the issue.

1 Like

That seems to be it, it varies. It also seems to do so when I let off the gas. This all occurs usually in the first 200 meters but I have driven a car up to 30 seconds before it broke. I can not be positive about this, but as far as trouble shooting goes, I also cloned a CSR sandbox car I made a month or two ago, and exported that and it appears to be fine. I just ran it around the track for a minute and it is not exhibiting the same behavior.

I just went back through to reassess a few of the cars that are exibing this and at least one of them locks before midway through their RPM range when applying throttle. It also seems to behave different after restarting beam. Definitely the rev limiter is also happening. I can break an engine on one of these cars by spinning it backwards on the pavement and throttling it while it rolls backwards. I just beat on the car that I cloned from the months ago build and I can’t break it. I hope this helps.

Oh! i had this issue too, i think we’re desiging for the same challenge.
It seems that the intertia is really low, and then after a certain RPM, say 5000, making the throttle input 0 makes the engine lock, not stall. Just lock and never turn back on. I’d never seen anything like it.


These were the stock values it gave me, i’m pretty sure the inertia should be higher, and maybe less friction because the engine is so small it doesnt have enough torque to overcome it? Since beam basically 3/4’s the torque of an engine anyway.

I’ve got the same problem. Whatever small engine below 1000cc ends up locking up and breaking if I let the throttle go. It begins idling but whenever it register a throttle input above 2000rpm (without even hitting redline) it just drops to 0 when I let go and breaks completely. I tried everything, from lowering the cam profile, making the car lighter, to improving the engine cooling system but to no avail. Any thoughts?

I’ve fixed!!!
The friction value should be under 20 more less. For some reason, the game identifies frictions over that value as a locked engine.
To fix you just need to edit this number with notepad.
Copy the camso_engine.jbeam out from the car’s zip file, edit it and replace the original on the zip file.
the mining of that value is pretty obvious:
more friction = slow response engine and more engine braking.
less friction = better response engine and less engine braking(supposedly).
I reckon 5 is a ok value.

1 Like

I will try to create a how-to topic to show how it’s done(if it hasn’t already)

This is also a problem for me if I have such an engine and turn the ignition off, the engine locks up. It’s a quick way to figure out if the engine is going to work properly.

I just wanted to add to this topic and state that, despite the recent updates to both BeamNG and Automation within the last week or so, this issue STILL exists.

I have a thread of my own I just started for the same problem…smaller engines instantly ‘locking up’ in BeamNG when you start to accelerate away:

Quite frustrating as the same small engines always used to work fine in BeamNG/Automation about 2-3 updates ago, so something has changed. Hopefully the issue is still being worked on so it can be fixed! :slight_smile:

1 Like