Game not starting, need help

Basically, every time i try to start the game, the loading screen appears, and when i click ‘play demo’ the game appears (along with music) then this warning comes up, is there any way to fix this quickly?

EDIT: have also tried running as admin (as suggested on other threads) but this had no effect on the error

Hi alex,

This is most likely due to the vc redist failing to install correctly.

Can you download and give this a go:

I guess it worked for him. I just loaded the latest build (160 I think) and i get that error when loading only with the graphics cranked all the way up. With them one step down I got the error when I selected the valvetrain type on the v-8. I did the “automation cleaner” and reinstalled without redownloading. It seemed to fix the crash while playing, so I turned the graphics back up and got the error while loading again. I went to the link in the previous post and reinstalled the redist software but I still get the same error at the same time under the same settings. I’m running AMD Phenom 4core and ATI radion 4600 serirs for video.

With the “turning the settings back up”, is that all the way up, to the warning message? (This setting is very graphically intensive. It can cause very poor performance …), as my computer with a Radeon 5850 struggles. The crash could be caused by the graphics card running out of video ram. Not sure how much your Radeon 4600 has, but the very high setting uses 400mb in render targets alone, so not including textures used by models, UI, text.

I have lost the context to what settings, is the loading crashing at high settings, or lower settings?

Yes, “turning the settings back up”, means to full quality. The only setting that I am getting the error at right now is at full quality. One click down from that and I’m good. I’ll have to check on the the video card RAM spec. If the error is due to performance I can live with that. “Same error at the same time under same settings” was refering to the high quality setting.