Goggles are back

Well, I tried to run Automation after two months.
After workshop update stuff I ran it, and in time of loading, those errors happened (in order; second one appeared when I clicked OK).
I haven’t tested the game without my actual cars/engines/companies/other files, but seems like that it would fine.

Any solution?

Backup your cars and engines then reinstall the game from scratch.

See if that works, then put your cars & engines back.

Not sure if all mods will reinstall.

They should do because it checks the mods and updates any that you are subscribed to.

Instead of reinstalling just try to verify game cache first, that is basically like reinstalling without having to download it all again.

  1. Game runs perfectly (well said on Kee engine…) without my current files and cars
  2. You sure that it will help? If not, let’s just wait for bugfix update xD

A verify game cache doesn’t hurt in any way, it just takes a little time.

If it won’t work, let’s just wait for the fix :stuck_out_tongue:

Umm, still getting that when trying to load previously made (older) cars.

Any fix? :frowning:

Now it would load front menu, and this thing pops up after goggles (I can bring them if you need)

Lua Error:
Step() failed!: [string “–client/functional/frontmenu.lua…”]:353: attempt to index field ‘vp’ (a nil value)

If it happens with older cars those probably at some point got corrupted by a broken version of the game or are so old that we don’t support them anymore. There is nothing we can do about that.

Okay then, sorry for taking your time :stuck_out_tongue:

Well… Yesterday I ran Automation and the problem fixed itself o.O