L4 Turbo Crash

A combination of some parts on an L4 causes the game to crash.

I may need to check again, but when I trying to rebuild my crashing 4A-GE from the ground up, the game crashed when I selected performance intake after selecting direct injection and turobocharging. This explains why the game was insta-crashing on my pre-update 4A-GE when I tried to convert to DI and turbo.

Is it throwing an error message?

No error, just the standard “Automation Launcher has stopped working” message.

EDIT: Think I may have figured out something.

Build a turbo straight-4 with random-ass parts all the way up to the fuel section. And then select Direct-Injection, ITBs, and race intake. Now go back to the aspiration section, remove, and reinstall the turbo.


Take this engine and try to turbo it. It’ll immediately crash on you.
4A-GE 20V Black TopRev1.lua (46 KB)

Found the crash, and it’ll be fixed in the next version. Thanks Hashiriya

Sorry for the bump, but i seem to have the same problem on all blocks, no matter what parts i use, i never had this problem before, tried a fresh install, and it still crashes. Again, sorry for the bump, figured bumping a similar topic beats a new one with a similar problem

Well that’s interesting. I found the problem too. Thought it was just a random crash. Anyways, as there has been graphical and bug fixes, will we have to wait for the car designer or will there be a small update ?

There will be a small update very soon.

I hope that solves this error from appearing again but time will tell

Thanks a lot for the answer. Let’s wait and see then…