Launcher crashes when pressing Play Demo

I used proper way of downloading at first through the launcher, but never succeded in starting Automation.
Yesterday I downloaded the files seperatly, and ran the cleaner, and then installed them.
Now I have Launcher Build 49, Automation Game Build 1113.

It still crashes.
Its a 64bit win7 Pro, and the fail-message I get from windows is as following; (Danish translation in paranthesis)

Problemsignatur: (Problem signature)
Navn på problemhændelse: APPCRASH (Name of problem event)
Programnavn: Automation Launcher.exe (Program name)
Programversion: (Program Version)
Tidsstempel for program: 521b077a (Timestamp for program)
Fejlmodulnavn: AirfoilInject3.dll (Error module name)
Fejlmodulversion: (Error module version)
Tidsstempel for fejlmodul: 4ec57787 (Timestamp for error module)
Undtagelseskode: c0000005 (Exception code)
Undtagelsesforskydning: 00001590 (Exception delay/exception time shift/Exception displacement (Not sure how to translate this)
OS-version: 6.1.7601. (OS-version)
Landestandard-id: 1030 (Countrycode standard ID)
Flere oplysninger 1: b95c (More information 1)
Flere oplysninger 2: b95ce8f131eada50dbc2db435b310722 (More information 2)
Flere oplysninger 3: ff45 (More information 3)
Flere oplysninger 4: ff456c33feb068146f4470e2737ac001 (More information 4)

I am really interested in this after my brother showed me, but ofcourse, I have no interest in buying something, that isn’t able to run on my computer.

Hope you have a fix,
Rune from Denmark

Just to make sure it’s not the cause of any problems: have you tried deactivating all the graphics options (lower resolution, turn off FXAA and SSAO) in the Launcher menu and set it to run in windowed mode?

I have just downloaded the demo and have lowered all of that and the demo crashes upon launch.

To Killrob:
Yes, also tried with everything lowered and off, and in windowed. Its the same

If you send us the KeeEngineLog.txt and the log.txt you find in your Automation folder in “My Documents”, we can take a look to see what is going wrong. :slight_smile:
Getting a DXDiag would help too: … ation_File

No such files exist (They dont get created). Screenshot is after 3 failed launch attempts in both fullscreen and windowed, all graphic settings lowered.

Also attached is DxDiag
automationDxDiag.txt (28.8 KB)

Hmm, this is curious indeed. I’ll ask zeussy about this.
Just for completeness sake: did you install the demo into its default directory?

Yes - ran a fully standard install

Launcher updated today. Same error

We are sorry you are having this much trouble with getting it to run :frowning:
It’s currently difficult for us to look into this, as the only one competent to really do so (zeussy) is traveling at the moment.
We’ll get back to you asap though!

No worries mate, hope I’m not stressing anybody out :slight_smile:

Its okay :slight_smile:

Anything new???

I’ll follow up with Zeussy again when he’s back in the office :slight_smile:

Still waiting :slight_smile:

Updated today, launcher 49, game 1323.
Now i get another error;
Failed to start Automation: Attempted to read or write protected memory.
This is often an indication that other memory is corrupt.

System.NullReferenceException: Objektreferencen er ikke indstillet til en forekomst af et objekt.
ved Automation_Launcher.AutomationLauncherWindow.UnloadDLL()
ved Automation_Launcher.AutomationLauncherWindow.btPlayDemo_Click(Object sender, EventArgs e)
ved System.Windows.Forms.Control.OnClick(EventArgs e)
ved System.Windows.Forms.Button.OnClick(EventArgs e)
ved System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
ved System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
ved System.Windows.Forms.Control.WndProc(Message& m)
ved System.Windows.Forms.ButtonBase.WndProc(Message& m)
ved System.Windows.Forms.Button.WndProc(Message& m)
ved System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
ved System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
ved System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Indlæste assemblies **************
Win32-version: 2.0.50727.5472 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

Automation Launcher
CodeBase: file:///C:/ProgramData/Automation/Automation%20Launcher.exe

Win32-version: 2.0.50727.5468 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/

Win32-version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/

Win32-version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/

Win32-version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/

Win32-version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/

Assemblyversion: 1.0.2902.0
CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX.Direct3D/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.Direct3D.dll

Assemblyversion: 1.0.2902.0
CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.dll

Win32-version: 2.0.50727.5472 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

Win32-version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/

Try downloading and installing this. Bit of a long shot, but it might be a broken runtime install: … px?id=5582

Another longshot is to ask if you are using some RAID setup, I remember someone having trouble with that before.