Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Can't start UE4 version


I recently bought the game on steam and everything worked well untill i tried ue4 version. When i click it to start menu closes, steam says running for 1-2 seconds then nothing happens, steam syncs and game closes. I checked if it was trying to run in background but it isnt, it just dies…

I tried file verification and directx reinstall, didnt fix my issue.

  • What if you try starting it in Safe mode?
  • What are your system specs?


Yes, safe mode also doesnt work.
I will only be able to access my computer tomorrow so i"ll tell as soon as i check it (at this point i think you realised i dont know much about computers). I only know its graphics card (nvidia 710m) (and its a laptop)


Sorry the UE4 version doesn’t work for you. The best bet will be to get your game log file to see what is going on, maybe that contains a clue to why it’s failing. You find the log file by pasting this address (including the % stuff) into your windows explorer address bar.


Just open it and see if there is anything in there that seems relevant… if the file exists at all. If it is a longer file, you can send it to us via email to contact@camshaftsoftware.com mentioning this thread :slight_smile:


That file doesnt exist in appdata
Edit: there is an automation folder in steammaps/common ; is that useful


I still need help


If you look for appdata in windows, the first thing that pops up is the Roaming Appdata. Click out of Roaming and you will find this

The one you want is Local. You should find the folder AutomationGame there.


Yes thats the issue, there isnt any. I checked my backup user and it doesnt appear in that one too
I’ll try again tho

Edit: btw is it normal if game starts with cmd


I found game log and game log error in my documents section are those what you seek (still no file in local tho)


Wait, are you playing Kee or UE4? Kee opens with the CMD. UE4 should not.


Kee, ue4 wont even start. Thats the issue


So the folder is there but there’s no log file?
Just to be sure, this is the path where we expect the file to be


It would be found in that folder only, other log files are either old ones or from the Kee Engine version (that one is found in Documents\My Games\Automation)

The steamapps/common/Automation folder is the default Steam install folder for Automation.

We need more information on when exactly the crash happens: do you get into the launcher where you see the recent news posts and can select to start either the Kee or the UE4 version? If so, how far into the loading of the UE4 version do you get before it crashes?


Just checked out your graphics card specs. While it sure isn’t the fastest, you still should be able to play on low-medium settings. I doubt it has anything to do with the crash, but its drivers could. Have you updated your graphics drivers any time recently?


Well its a little late since i refunded the game to grab smt else while it was on sale. Thanks for help anyways but i still would like to help you.
Crash happens right after i click play open beta, window closes steam says running for a second (nothing happens of course) and then it syncs and stops thats all
There is no file in appdata anywhere also i ran a file validation check, steam said there was nothing wrong.
Yes my drivers are up to date.
This is all i know about the problem, i checked steammaps folder for logs too but didnt find anything
Am i the first person to have this kind of problem?


Thanks. Maybe not the first one but this is a very rare issue, maybe a 1/1000. Usually it at least gets a little further into loading the game and creates a log file which then tells us what’s going on.


I bought the game and have played on my main pc with no issues. Today i loaded it on a second pc and when i try to start the UE4 version it crashes on startup. I checked the .log file and it has several errors, listed below. Note, the game is installed on my C: drive.

[2018.02.22-14.50.05:106][ 0]LogWindows: Error: Error: Assertion failed: Assertion failed: err == SQLITE_OK [File:d:\workspace\AutomationGame\Source\AutomationGame\LuaGameInstance.cpp] [Line: 150]
unable to open database file

[2018.02.22-14.50.05:106][ 0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: === Critical error: ===
[2018.02.22-14.50.05:481][ 0]LogWindows: Error:
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: Assertion failed: err == SQLITE_OK [File:d:\workspace\AutomationGame\Source\AutomationGame\LuaGameInstance.cpp] [Line: 150]
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: unable to open database file
[2018.02.22-14.50.05:481][ 0]LogWindows: Error:
[2018.02.22-14.50.05:481][ 0]LogWindows: Error:
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: KERNELBASE.dll!0x00000000DD814008
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!ULuaGameInstance::Init() [d:\workspace\automationgame\source\automationgame\luagameinstance.cpp:154]
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!UGameEngine::Init()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!FEngineLoop::Init()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!GuardedMain()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!GuardedMainWrapper()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!WinMain()
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: AutomationGame-Win64-Shipping.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253]
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: KERNEL32.DLL!0x00000000DEEC1FE4
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: ntdll.dll!0x00000000E131EFC1
[2018.02.22-14.50.05:481][ 0]LogWindows: Error: ntdll.dll!0x00000000E131EFC1
[2018.02.22-14.50.05:481][ 0]LogWindows: Error:


That does look like the game doesn’t have access to the save path location. That can be either due to restricted user access, or anti-virus programs like Bit Defender blocking its access to the path. I’d check both possibilities.


Stupid Bitdefender…Thankyou!