Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Game Crashes on Startup (UE4)


#1

When I go to start up the game in Unreal mode, it looks like it is going to launch, but then it shows an error/crash report. I have tried uninstalling and reinstalling the game, starting in different versions, so what gives?

Any help would be much appreciated.


#2

EDIT: The details say

Fatal error: [File:D:\workspace\UE4-Camso\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 233]
Result failed
at D:\workspace\UE4-Camso\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:289
with error 8876017C

KERNELBASE.dll!0x00000000994AA388
AutomationGame-Win64-Shipping.exe!FOutputDeviceWindowsError::Serialize()
AutomationGame-Win64-Shipping.exe!FOutputDevice::Logf__VA()
AutomationGame-Win64-Shipping.exe!FDebug::AssertFailed()
AutomationGame-Win64-Shipping.exe!VerifyD3D11Result()
AutomationGame-Win64-Shipping.exe!FD3D11Viewport::PresentChecked()
AutomationGame-Win64-Shipping.exe!FD3D11DynamicRHI::RHIEndDrawingViewport()
AutomationGame-Win64-Shipping.exe!FRHICommandListExecutor::ExecuteInner_DoExecute()
AutomationGame-Win64-Shipping.exe!FRHICommandListExecutor::ExecuteInner()
AutomationGame-Win64-Shipping.exe!FRHICommandList::EndDrawingViewport()
AutomationGame-Win64-Shipping.exe!FSlateRHIRenderer::DrawWindow_RenderThread()
AutomationGame-Win64-Shipping.exe!FSlateRHIRenderer::DrawWindows_Private()
AutomationGame-Win64-Shipping.exe!FSlateApplication::PrivateDrawWindows()
AutomationGame-Win64-Shipping.exe!FSlateApplication::TickApplication()
AutomationGame-Win64-Shipping.exe!FSlateApplication::Tick()
AutomationGame-Win64-Shipping.exe!UGameEngine::CreateGameWindow()
AutomationGame-Win64-Shipping.exe!FDefaultGameMoviePlayer::Initialize()
AutomationGame-Win64-Shipping.exe!FEngineLoop::PreInit()
AutomationGame-Win64-Shipping.exe!GuardedMain()
AutomationGame-Win64-Shipping.exe!GuardedMainWrapper()
AutomationGame-Win64-Shipping.exe!WinMain()
AutomationGame-Win64-Shipping.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253]
KERNEL32.DLL!0x000000009B703034
ntdll.dll!0x000000009C2D1431
ntdll.dll!0x000000009C2D1431


#3

Hey!
Have you tried the various potential fixes listed in the Troubleshooting FAQ yet? :slight_smile:


#4

Sorry for the late response, but yes. I have tried everything and it does not work for me


#5

That includes getting the latest version of DX11?


#6

Yes


#7

Thanks @HondaFanboy for submitted error reports with your email address in them. Made it possible to find the logs.

The game is giving the following:

[2018.07.07-05.32.11:352][ 0]LogD3D11RHI: Adapter Name: NVIDIA GeForce 940MX
[2018.07.07-05.32.11:352][ 0]LogD3D11RHI: Driver Version: Unknown (internal:Unknown, unified:Unknown)
[2018.07.07-05.32.11:352][ 0]LogD3D11RHI: Driver Date: Unknown

I just noticed that updating your drivers is not in the Troublshooting FAQ, so if you have not given that a go yet. Please do so. https://www.geforce.com/Drivers


#8

Still not working :confused: , What should i do? I have updated the drivers and it is still crashing.


#9

:sob:

This is strange, I have not seen a crash like this so early in startup. It is before it even starts to load any levels or assets.

Googling the exact error (D3D11Viewport.cpp
with error 8876017C) in the logs brings up this: https://forums.funcom.com/t/i-cant-play-the-game/18077

Who has the same 940MX as you So you are not alone in this.

Reading this long thread on the issue: https://steamcommunity.com/app/427290/discussions/1/1697174779864185373/

Seems that maybe a Windows 10 update has sort of screwed up the ability for UE4 to correctly select/run/use the Geforce 940MX over the Integrated Intel Chipset.

Quoting Emil from that Steam Thread:

I fixed it on my machine.

Download the ZIP file from here: https://downloadcenter.intel.com/download/27847/Graphics-Intel-Graphics-Driver-for-Windows-10?product=80939
NOT the executable (it won’t work for everyone)

Use the directions found here to install, even if the driver is unsupported by the manufacturer:
https://www.intel.com/content/www/us/en/support/articles/000005474/graphics-drivers.html

(Nb. I’ve not actually tried playing with the new drivers installed… but the game at least runs now)

EDIT: Fortnite also works now
Also, another option for fixing this, for those who have the option, is to disable integrated graphics in the BIOS.

A reddit thread I found on this, the player fixed it by rolling back a Windows 10 version from 1803 to 1709. It looks like my work machine is still on 1709.


#10

ok. Will I have to rollback my windows version for it to work?


#11

Seems a lot of people had luck with updating the intel drivers.


#12

Unfortunately, no drivers could help anything, so I had to roll back my windows version. But it does work now!

Thanks for your help.