Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Game has slowed to a crawl


Hello to All. I’ve just been able to start to play Automation this evening, 2145 EST, US. For some reason, the game has slowed to a crawl and is now unplayable. Yesterday, Automation worked just fine. I made sure that my drivers were the latest, and they are. HELP!!!

HP Omen 15-ax252nr
Intel i7-7700HQ
Windows 10 Pro
GeForce GTX 1050 Ti


Ok, few things I can think of right off the bat:

  1. Did you check your game settings are appropriate?
  2. That sounds like a laptop, are you sure it isn’t throttling massively? Maybe prop it up with a book or something and see if it gets better.
  3. Related to the previous, maybe it has clogged up with dust completely?
  4. Are you sure there isn’t something else intensive running in the background?
  5. Has/have the RAM stick(s) managed to wiggle themselves loose?
  6. Have you got some battery saving power plan or something going? Does performance improve if you plug it in?


Alongside what Ram said, I would also start it in safe mode, to be safe, as that starts the game on the lowest possible settings.


When I first loaded the new Beta it was crawling, but after restarting the game it seems to be working much better now. I am down about 5-10FPS from what I was but still very playable.


Okay, so discovered that I had to update my NVIDIA GeForce GTX drivers and reboot. Working well so far, except that I used to be able to run in EPIC mode completely, and now must Resolution Scale at HIGH, instead of EPIC. If I run Resolution Scale in EPIC, the graphics “stutter”. Thanks and Happy New Year!