Home | Wiki | Live Chat | Dev Stream | YouTube | Archived Forums | Contact

Pixel Shader Required?


#1

Well…here’s another weird error for the list:

My current Machine runs an MSI/Nvidia GeForce GT 730, which is a pretty capable GPU so far despite not having Pixel Shader enabled.

Please let me know if there is a fix for it…


#2

Mmm, that shouldn’t be happening, that card supports Pixel Shader 5.0, so it’s plenty new enough.

Maybe try reinstalling/updating graphics card drivers?


#3

Alright…i’m downloading and reinstalling the latest official driver (v382.53) from Nvidia right now. I’ll keep you posted on the progress ASAP.
UPDATE: Nope. It didnt work. Neither fixing the C++ 64-bit Redistributable. What else now? :confused:


#4

Do you have an integrated GPU that might be getting detected and used erroneously? There might be something in nVidia Control Panel to force Automation to use your GT 730 if that’s the case. I don’t have an nVidia card, so can’t really advise (and I’m feeling decidedly brain dead right now).


#5

Can you please show screenshot from device manager? (my computer->right click->properties->topish left, device manager->graphics card, try expanding it if possible.) You can take only device manager window screenshot by making that window active and hitting left alt + print screen on keyboard.


#6

Nope…it’s the only one running at the moment (no On-board Graphics Accelerator is present AFAIK; BTW It’s shown in LATAM Spanish, if you will.)


#7

The only other thing that immediately comes to mind is to try reinstalling DirectX.


#8

Alright…I’ll be trying that one right now.
Just Got the 2010 DX Redistributable from Microsoft.
Installed without hitches. About to start testing thorough the regular launcher.
Nope. It still refuses to load and that stubborn error message keeps popping up.
Exiting the Beta program to check if that’s causing the glitch. Nope either.
Validating files: Complete. That freakin’ error message has surfaced again.
…and Yours Trully went out of ideas. Any other sugguestions?


#9

Iv searched through google, but all iv found was similar issue, sadly unresolved. Only thing iv found somewhat helpful was nvidia control panel(some kind of setting there), sadly there was no details aswell.


#10

What is “it”? What is refusing to load? The launcher or the game?

The message is brought up by our game Launcher and can miss-detect stuff. Hence is just being a notice and stating “If this is correct Automation will not work. Do you wish to continue anyway?”. You can click Yes to continue through it.

Can you play the game? You can skip the launcher by selecting one of the circled options in Steam:

The top one being the classic Kee Engine version.
The bottom being the new UE4 Version. (Only available if you select the open beta branch in the game properties in Steam)


#11

For sure. Its the game’s launcher the one which is refusing to load up, so there must be some missing component that’s causing “it” to glitch momentarily, throwing the aforementioned “warning” message. (My machine’s GPU can support the latest version of Pixel Shader as per my latest check, although i could upgrade it to a better part later.) As for the game itself, the “Unreal” version plays beautifully so far, although it could use some additional fixtures, like some cool exhaust tips to give it some extra styling points to those car bodies.

Let’s keep that great work up front, guys!


#12

Winky Face


#13

UPDATE: Just came back from a System Refresh procedure and GPU Driver update -to v384.76- -and a thorough reinstall of every piece of software and game available, Steam included.- about a couple weeks ago. I’m glad to inform that everything is running great so far.

Well…almost.


I wonder if that one got fixed yet. (Yup…that infamous “bubble gum” car body glitch from last December, which is similar although unrelated. It’s from the “Kee” version of course.)


#14

That’s found on some mod bodies that haven’t had their .lua files updated.

To fix it, just get into the “body” .lua files for it and find the materials list (all start with ECS_) and add " " on either side.
This way, ECS_Body becomes “ECS_Body” and so on. Just run a search for pink bodies and more detailed solutions should come up if needed.


#15

Example how it should look like.