4.2 issues with fmod / game has no sound

Sadly, since updating to the new alpha version patch, the game doesn’t have any sound. It also crashes while exporting cars on ‘sourcing lua data’.
I already tried: Updating my sound drivers (they seem to be up to date), checking the game files’ integrity, reinstalling the game, a combination of both, also restarting my computer.
Also, as of the windows volume mixer, the game does not output any sound. None of the hotfixes has fixed this problem.
Below I have linked the most recent log file of the game I have, where both isses ocurred.

Automation Game log

I hope anyone can help me. Also thank you to anyone who gives my problem a thought and wastes a little bit of their time. cheers.

I’ve just had a look and have no issues with the sound. Music plays, engine revving has sound and the car makes a noise going around the track.

The exporter is also working for me.

What game build are you running? This is at the bottom right of the main menu screen.

Finally, 176Mb seems to be a little bit on the large size for a simpe log file…so didn’t download it to look.

About the file size: that seemed a bit off to me too. I attached a screenshot of my logs folder.

My game’s build number is 211224.17926.5859.Manual

I have some at around 200KB! Nothing like the sizes you have in there.

The only things I’d suggest is delete the cache.
Uninstall completely and reboot your PC. Then try a reinstall.

So I had a look inside the file. What I noticed even though not having a clue what exactly that means is, that the game over and over logs an FMOD error.

I’ copy the first time this error occurs in that log file in here as text.

Blockquote

[2021.12.25-22.27.17:451][ 0]LogFMOD: FFMODStudioModule startup
[2021.12.25-22.27.17:451][ 0]LogFMOD: Lib path = ‘…/…/…/AutomationGame/Plugins/Runtime/FMODStudio/Binaries’
[2021.12.25-22.27.17:452][ 0]LogFMOD: FFMODStudioModule::LoadDll: Loading …/…/…/AutomationGame/Plugins/Runtime/FMODStudio/Binaries/Win64/fmod.dll
[2021.12.25-22.27.17:519][ 0]LogFMOD: FFMODStudioModule::LoadDll: Loading …/…/…/AutomationGame/Plugins/Runtime/FMODStudio/Binaries/Win64/fmodstudio.dll
[2021.12.25-22.27.17:607][ 0]LogFMOD: Error: ‘FMOD::Debug_Initialize(FMOD_DEBUG_LEVEL_WARNING, FMOD_DEBUG_MODE_CALLBACK, FMODLogCallback)’ returned ‘A command issued was not supported by this object. Possibly a plugin without certain callbacks specified.’
[2021.12.25-22.27.17:624][ 0]LogFMOD: Display: Loaded bank lookup
[2021.12.25-22.27.17:625][ 0]LogFMOD: Display: Loaded asset lookup
[2021.12.25-22.27.17:987][ 0]LogFMOD: Error: ‘lowLevelSystem->getDriverInfo(DriverIndex, nullptr, 0, nullptr, &SystemSampleRate, nullptr, nullptr)’ returned ‘Error initializing output device.’
[2021.12.25-22.27.17:987][ 0]LogFMOD: Default sample rate = 48000
[2021.12.25-22.27.17:987][ 0]LogFMOD: System sample rate = 0
[2021.12.25-22.27.18:509][ 0]LogFMOD: Error: ‘StudioSystem[Type]->initialize(Settings.TotalChannelCount, StudioInitFlags, InitFlags, InitData)’ returned ‘Error initializing output device.’
[2021.12.25-22.27.18:509][ 0]LogFMOD: Warning: Failed to load bank: …/…/…/AutomationGame/Content/FMOD/Desktop/MasterBank.bank (An invalid object handle was used.)
[2021.12.25-22.27.18:510][ 0]LogFMOD: Error: ‘FMOD::Debug_Initialize(flags, FMOD_DEBUG_MODE_CALLBACK, FMODLogCallback)’ returned ‘A command issued was not supported by this object. Possibly a plugin without certain callbacks specified.’
[2021.12.25-22.27.18:586][ 0]LogUObjectArray: 17538 objects as part of root set at end of initial load.
[2021.12.25-22.27.18:587][ 0]LogUObjectArray: 2 objects are not in the root set, but can never be destroyed because they are in the DisregardForGC set.
[2021.12.25-22.27.18:587][ 0]LogUObjectAllocator: 3573048 out of 0 bytes used by permanent object pool.
[2021.12.25-22.27.18:587][ 0]LogUObjectArray: CloseDisregardForGC: 17538/17538 objects in disregard for GC pool
[2021.12.25-22.27.18:603][ 0]LogEngine: Initializing Engine…
[2021.12.25-22.27.18:606][ 0]LogHMD: Failed to enumerate extensions. Please check that you have a valid OpenXR runtime installed.
[2021.12.25-22.27.18:610][ 0]LogStats: UGameplayTagsManager::InitializeManager - 0.001 s
[2021.12.25-22.27.18:646][ 0]LogStreaming: Error: Couldn’t find file for package /Engine/EditorMaterials/GizmoMaterial requested by async loading code. NameToLoad: /Engine/EditorMaterials/GizmoMaterial
[2021.12.25-22.27.18:646][ 0]LogStreaming: Error: Found 0 dependent packages…
[2021.12.25-22.27.18:646][ 0]LogEngine: ERROR: Failed to load special material ‘ArrowMaterialName’ from path ‘/Engine/EditorMaterials/GizmoMaterial.GizmoMaterial’. This will probably have bad consequences (depending on its use).
[2021.12.25-22.27.18:904][ 0]LogPakFile: Precache HighWater 16MB

[2021.12.25-22.27.18:904][ 0]LogPakFile: Precache HighWater 32MB

Blockquote

Try the uninstall and reboot.

Go to your SteamLibrary/steamapps/common and, if it’s there, delete the Automation folder.

Then try a reinstall.

Well I tried a reinstall (with a complete whipe) but I’ll try again with a computer restart in between.
I also tried switching audio devices and plugging out some of them. Didn’t change anything.

Update: Sadly it didn’t help.

[2021.12.26-01.02.31:457][ 1]LogFMOD: Error: ‘ClockSinks[EFMODSystemContext::Runtime]->LastResult’ returned ‘An invalid object handle was used.’
[2021.12.26-01.02.31:459][ 1]LogFMOD: Error: ‘System->setListenerAttributes(ListenerIndex, &Attributes)’ returned ‘An invalid object handle was used.’

I can’t see why you’re having issues.

I’m guessing all your drivers are up to date?

I believe so. At least for my headset I checked via the windows device manager and its own software (Logitech G HUB). Any other advice regarding drivers? Or updating an fmod application/driver anything of that sort?

What happens if you plug headphones/speakers into the green speaker jack?

If you opt out of the Alpha, do you get sound on the stable release?

I have speakers in the speaker jack on my mainboard. I have tried both with (default) and without them plugged in, the same with my USB-Headphones.

I just checked again: On the stable release I have sound and the car exporter also works just fine.

i’m having the exact same issue, does anyone if there is a fix? it works fine on the stable release but on every version of 4.2 I have this exact issue as described here.