Cannot save new engine family

If I go through the engine sandbox and make a new engine, it’s not saved, even if I save manually.
If I go through the car creator, once I get to the engine part, I cannot proceed because no engine is created.

I did see the solution with the Controlled Folder Access changes, but mine is turned off. Also, I can totally see my previous builds, including existing engine families. I have tried verifying files with steam, and reinstalling (but not blowing up all my previous builds)

I checked the logs, did find a fun stack trace, but it does not seem to be permissions-based:

============Error: no such column: TechPool

I can paste more of it if it’s helpful. I should note that I haven’t tried to play this game in quite some time. Not sure if there’s some sort of migration that was missed. I will blow up all my existing builds to start fresh if I must, but I’d rather not if it can be avoided.


This looks like an issue with the database itself for some reason. Could you try to make a backup of it and then Clear Saves in the game launcher?

You can zip the Documents\My Games\Automation folder and put it somewhere safe to back it up.

Yay! I can sav engines again. Thanks!
From here, is there a way I can restore what I had built previously?