Can't create new car/engine due to .lua errors when starting engine designer on its own

I just tried starting up the game again after a power cut, and got these error messages:

Specifically, if I try using the engine designer at all by itself (without creating a car first), the entire game becomes unplayable! I tried clearing my cache, to no avail - what should I do to fix this? Should I just clear my saves (which removes everything I had built so far - at least I backed it up beforehand) or verify integrity of game files?

Edit: I tried the latter, and it had no effect - it must be a database error. Is there any way this can be fixed without clearing saves or even reinstalling the game from scratch? On the other hand, immediately creating a new car, then creating a new engine from the ground up (not using an existing variant or cloning a variant) works just fine.

As per that first lua error, your database has been corrupted after the power cut. All you can really do now is export any .cars you haven’t already backed up (which may fail if they’re corrupted), delete your sandbox db (C:\Users\[your username]\AppData\Local\AutomationGame\Saved\UserData\Sandbox_211122.db) and start again by relaunching the game, and importing the old cars and engines.

It worked. Thankfully I backed up everything in the Export folder beforehand. Thanks!

1 Like