Car exporting without sound

I’m on build 200401.12304.2085 and I’ve tried exporting this car twice, but it has no engine sound in BeamNG, however all other sounds seem to work fine. (36.3 KB)

1 Like

Have you tried to clear your Beam cache? i.e., are you sure the problem lies with Automation here?

I know it was working just fine yesterday and nothing else really changed, but i’ll give it a try

I have done that and there is still no sound. as for if automation or beam issue, I wouldn’t know how to tell, though I will crosspost to Beam support if necessary.

Alright, we’ll have a look!

1 Like

Looks like we fixed the issue, should be good in the next patch. Cheers!


Hi, roughly when is the next patch supposed to come out?

It is out now, but only on openbeta of course. Stable also doesn’t work in that regard. We’re looking into getting that fixed there too without changing anything else.


Hi, I am a new user just installed the game + a few days ago… I am having the same issue with all of the cars I exported all of the sudden having no sound. I cleared Beam cache and restarted automation + tried loading an earlier save and same issue. Frustrating because everything was working great up until I started deleting cars from the beam mod folder. I have cleared everything and tried exporting fresh, still nothing works

I’m having the same problem. I think I’ve made some headway on what’s causing this issue. First off, it isn’t a problem with Beamng drive. It is a problem with Automation. What is happening is that the engine file in the sound folder, of the art folder, of the car mod (for Beamng Drive) isn’t being created and exported by Automation when you export a car into Beamng Drive. For some reason newly made engines in Automation that have been created after the last update (LCV4.2) have this problem. However, if you use the same car and place a different engine that was created in the previous version (LCV4.1), you won’t have this problem. I think that there is an engine sound export glitch that is occurring in the software. This is as far as my testing has gone. I don’t know if it is happening with all engines. However, I know for sure that it is happening with turbo charged, DOHC, 90 degree, V6 engines. I don’t know if this is significant or not. If one of the developers is listening, please take a look at my notes and see what you can do. Thank you.

Can confirm what StregoX9 says, have the same issue. Tried R4, V8t etc and Automation apparently doesnt export engine sounds anymore. There are only exhaust sounds.

I’ve just had this exact same problem as well. I made a N/A, 60 degree, V6 and stuffed that into a race car. No mods were used. I’m also getting a warning in the export menu. "This is a user-created export plugin. Use at your own risk.’’

I’ve done some more testing, and I can confirm that this occurs with any new engine builds after LCV4.2. I’m also getting the same message as ThomasA-N. However, I’m not sure what that means here.

Hi yea i also installed the game today and have the same problem

I am afraid it is a problem rather on Beam.NG side.

I also have it. However the same car on different PC works fine and it has been recently exported.

I recieved first submissions from a challenge I made and participants are reporting their cars to work fine on their side.

I just recently read today from Killrob that there engine sound recording license expired, and they’re working to get it back. This is affecting some people’s ability to get engine sound folders. A separate company (Concert [I think]) licenses engines sound for export to Beamng. They’re currently working to patch it.

On March 6, 2021 @ 8:10 PM (EST)
Killrob has release a new hotfix for this issue (LCV4.1.18 [Hotfix]). The engine sounds should work now. I’ve tested it on my computer, and it is working. I’m currently using the openbeta - Public Test Branch beta. That’s were I’ve confirmed the fix. Give it a try and see if it helps any of you. Also, be sure to accept the license agreement at the export screen, or it won’t work.


verything was fine a week ago!
Sounds were exported flawlessly and without gaps.
But then my “ААЗ-2109” became silent !!!
At first I thought that it simply did not load, but there is no sound in the folder AT ALL NO!
Please, help me!

this Oh so aggravating exhaust export problems happening again,
sounds not being exported only engine pops and bangs and shifting noises no motor tone on any motors
just started recently

I agree with you
When will they trample it once and for all ?!

How recently? Because I made an RNG-based car in Automation yesterday, and the sound was perfectly fine.