Error Code 4028

I decided to update my client today after some time away but when i ran the exe i got a box pop up with it saying “Error Code 4028”. I tried uninstalling and reinstalling the client but it didnt seem to fix its self.

I am on x64 Windows 7, any help on this issue would be great :slight_smile:.

Did you just reinstall, or did you also download the files again? I don’t fully remember, but I think this might be the error message for corrupted files, so please try to uninstall (run the automation cleaner too) and try a fresh download.

Hope that works out!

Starting my old install of the public build, I’m getting the same error. Just wanted to let you know that we’ll look into this as soon as possible! Even if a fresh install fixes it.

Thanks for the reply, yes after uninstalling i redownloaded it from the link provided where my license key is but still got the error.


The issue has been resolved. Does it work for you again?

Redownloaded the installer but after it installed still the same error.

I’ll get Zeussy to take a look tomorrow when he gets back from overseas.

Okay, Thank you.

Any progress ?

Not on our side, but yes indeed. We looked into it and it seems to have been caused by a windows decryption thingie not working as it should… not having anything to do with Automation. On that day where everyone had the problem 4028, but that solved itself within a few hours, and since then it has been fine. That’s why we didn’t bother looking into it anymore because we thought that was fixed.

Even though it did look like it was related to connecting to our servers, it wasn’t: the point it crashed was before any kind of connection was even attempted.
If you’re still getting that problem, it is either connected to some very special settings on your computer, or a corrupt install - the latter being the more probable of the two possibilities.

Have you tried to re-download/install again? On a different drive even?
Hope this gets sorted out for you soon!

Yes installing it on my storage drive seems to have made it work. Cant believe i didnt think to try this sooner :unamused: