Fatal Error 22 & 13 Upon Startup

Hello All,
I have been having plenty of trouble with getting Automation to run so far. I have tried every tactic in the forums you can name, reinstalling the game, verifying the cache, reinstalling DirectX, .NET, and even following the advice from zeussy linked to here:


Nothing has worked so far until I followed zeussy’s advice, and I went from a “Automation_Shipping_Steam.exe has stopped working” to “Fatal Error” (picture attached). Also attached is the gamelog.txt, although it may not have much use. Any help will be appreciated, as at this point I am desperate to get this game to work. Thanks!
GameLog.txt (87 Bytes)

I assume you have not replaced the lua51.dll within the Automation install?

This looks like some other application is using a lua51.dll and windows is loading that for Automation instead of the one that comes with Automation.

You might want to try closing all other applications, or searching your computer for lua51.dll to try and find the culprit. This looks like it is a slight fault in the design for LuaJIT (as it is a drop-in replacement for lua51), they both have the same dll name, and windows DLL Resource management does not want to load duplicates of the same thing.

I have replaced lua51.dll with the link listed in the first post, and I now have lua51.1.dll in the same folder. I tried looking through my computer for another lua51.dll, found another copy in my “Downloads” folder and deleted it, but the problem still persists. I tried closing all applications and restarting several times as well.