Home | Wiki | Discord | Dev Stream | YouTube | Archived Forums | Contact

Game Crashes when trying to select Engine for Project

Hello,
Ever since upgrade of LCV 4.0 (or was it 4.1? Don’t remember for sure, but before the new map was announced) I’ve been having problems selecting an engine for an already stablished project. Creating an engine project is fine, it works, but when selecting it for a car project, with either option (Existing Engine, Copy Engine, New Variant, New Engine).

I have sent a few bug reports through the game report system, but unfortunately I don’ have any logs on my game folder in my documents. I’ve tried cleaning the game cache too, but that doesn’t seem to work. I’ve tried also playing in safemode, which is also another no-no.

Here’s the DxDiag:


System Information
------------------
      Time of this report: 5/23/2021, 17:20:48
             Machine name: DESKTOP-U674QQO
               Machine Id: {8BCE1948-CE99-4780-90F7-1DD3C35D70DD}
         Operating System: Windows 10 Home Single Language 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
                 Language: Portuguese (Regional Setting: Portuguese)
      System Manufacturer: Dell Inc.
             System Model: Inspiron 5437
                     BIOS: BIOS Date: 05/28/18 10:22:54 Ver: 04.06.05 (type: BIOS)
                Processor: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz (4 CPUs), ~1.8GHz
                   Memory: 8192MB RAM
      Available OS Memory: 8096MB RAM
                Page File: 6775MB used, 10537MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
 DirectX Database Version: 1.2.2
           DxDiag Version: 10.00.19041.0928 64bit Unicode
------------
DxDiag Notes
------------
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
          Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------

One thing I noticed is that there seems to be a spike in memory consumption before the crash, when I select the engine. The game freezes completely and the bug report thing pops up.

Could you try to backup your Documents\My Games\Automation folder and then delete it?
When you then start the game it will be on a fresh naked database. See if the issue persists then and let us know if that is the case or not.
Cheers

Well something weird happened. I deleted it, and it didn’t work, again crashed when creating the engine for a new project on a fresh campaign. No log on the folder either.
Then I tried running the .exe at UE424 with administrative permission just for kicks, and it worked! Two times out of three (it crashed once before booting, no idea why). I tried running both with chrome open, or closed. (major source of RAM consumption on my machine).

Now, what this means? I have no idea, still no logs to give you unfortunately :frowning:

Edit: I was trying to run the game through the launcher before this. The launcher pops a .NET error if I try running it with admin privileges.

It just means that indeed the issue is privileges, the game doesn’t have access to its database unless you give it admin privileges. :slight_smile:

Try to install the .NET framework linked here:

Oh was the admin privilege thing somewhere I missed? If I knew it was so simple it’d have saved me a lot of trouble :pensive:

Sorry for bumping the topic again. But again it crashed when selecting an existing engine. Again I tried running with admin privileges, and again it had no log. I tried installing .NET but it was already installing.
Literally have no clue of what’s happening now.

That is very odd. Do you run any anti-virus, windows defender, or windows protected folders?
Do you have enough space left over on your drive which holds the Documents\My Games\Automation folder?
Is the latter on an internal drive (as opposed to an external or cloud drive)?

If adding exceptions for the game doesn’t help, we’ll need you game logs. You get that by pressing the Game Log button in the game launcher. Send us the AutomationGame.log file to support@camshaftsoftware.com linking to this thread. :slight_smile:

1 Like

Has anyone found a fix for this yet? I’m having the same issue and none of the fixes here have worked.

I have the same problem

Oh yes my situation was followed up on email:
Turns out I have too little GPU and memory for the game and it’s too much for the system (Intel HD graphics). Playing on minimum settings with nothing else open seems to have made the issue gone, mostly, it still happens sometimes but there’s no proper solution it seems.