Game not loading up (even with updated drivers)

So today I tried to load up the Automation Game, and then when I clicked the Play button of the Game Launcher, I didn’t see anything loaded up at all, and then I found out that the game didn’t load at all. I figured out it could be the drivers, and so I updated the drivers. Still I tried with updated drivers, and the game still would not load AT ALL. Meanwhile BeamNG worked perfectly fine, should I delete saves and cache to reinstall the entire game, or what?

Sorry to hear you are having troubles getting the game to run. For quite a few a simple switch over to the latest version of the game currently in open beta will solve that issue.

Right-click Automation the game in your Steam Library, select Properties, Betas, then choose the openbeta branch. Then let the game update.

Once that is done start the game and get into its launcher, there you press the Clear Cache button. Then you can start the game with the Play button.

Give that a go and see if the game runs! If not, send us the AutomationGame.log file you get from pressing the Game Log button in the game launcher to

I am installing openbeta update to see if it works. I will tell you if it doesn’t work.