Game used to launch but doesn't after Beta version tried

I’m running Linux and Steam, I first bought and downloaded the game two days ago, worked OK (without the launcher only). I thought I’d try the Beta version so updated to that. It doesn’t run at all. So I thought I’d uninstall and start again with the non-Beta version, now nothing starts.

I’ve uninstalled and re-installed twice now, it must be something still held in Cache somewhere? (I’ve already cleared the Steam download cache) I just want to go back to my first install. Any tips on totally resetting the game from scratch would be appreciated. ‘Verification of files’ in steam shows no errors.
Thank you.

Did you opt out of the beta? back to stable branch? If you’re just launching from the steam popup that says launch with launcher, launch (ob) and launch without launcher then maybe check the properties tab of automation in steam. There you can verify files and also opt in/out of stuff.

Another thing to check is clearing the cache in automation from the launcher, there’s an option for it there.

Thank you for your response Riley, it turns out that when Steam runs a program it figures out it’s dependencies first and puts them in place, DirectX 10 etc. all those things needed to emulate Windows on Linux. There was the problem, Steam getting confused about what to run first before Automation. In the end I changed the ‘force the use of a specific program Proton 5.13’ and it re-installed DirectX and all that other stuff and off she went. Now works well. Thank you.
Kind regards,