Help Opening project files in UE4 editor (solved!)

Fast forward to the solution:

  1. Follow the tutorial until you get to the Open AutomationGame project part.

  2. Go into the Epic Launcher/unreal engine tab/yellow Launch button’s drop down menu; switch to version 4.17.2, if you don’t have it yet go to the Library tab above and click on the 4.20.1 button’s drop down menu and select 4.17.2 and install.

  3. Once that’s done, open the project file, and it will error saying to make a copy. At the bottom of the popup window chose More options… Skip conversion. Now the editor will start to open, give it 5-10 minutes to load the first time and another 15 to compile stuff. Don’t worry, the second time you load, it wont take forever.

Hi, I’m coming from BeamNG and do a lot of modding for that game. I would like to give modding this game a try. I can model in 3DS max and generally quick at picking up modding, so this seemed like a fun project. I made some mods for UE1 back in the day, but that was the last time I modded for this platform. I found the tutorial, and it seems easy enough to get started with.

What I’m having trouble with is opening the project files. I downloaded the UE4 version 4.17.2 and 4.20.0 using the Launcher and got the Automation Workshop Tools through Steam.

With 4.17.2, it errors out:

This project was made with a different version of the Unreal Engine. Converting to this version will rebuild your code projects.

New features and improvements sometimes cause API changes, which may require you to modify your code before it compiles. Content saved with newer versions of the editor will not open in older versions.

We recommend you open a copy of your project to avoid damaging the original.

I open a copy of it and I get this message:

Project files could not be generated. Log output:
Running E:/Games/UnrealEd/UE_4.17/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“E:/Games/SteamLibrary/steamapps/common/Automation_SDK/AutomationGame 4.17 - 2/AutomationGame.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
UnrealBuildTool Exception: ERROR: Directory ‘E:\Games\SteamLibrary\steamapps\common\Automation_SDK\AutomationGame 4.17 - 2’ is missing ‘Source’ folder.

It says there’s missing files, where can I get them? I get similar errors with the 4.20 version, but it also asks to download 10GB worth of Visual Studio support files.

Update; I found a UE4 thread that solved the source folder, by simply adding an empty folder. I tried loading it again and get these 2 errors:

I have no clue how to compile a dll file LOL. I have a hunch its related to Visual Studio 2017, so maybe there’s some configuration necessary with that software.

I just found this thread Tutorial UE4 modding - #18 by Daffyflyer and it seems to be discussing the same issue and its half a year old.

I don’t know what the deal is, but I did notice a change recently. It used to be that when you launched the UE4 editor, you had to click “more options” then click “skip conversion”, but now that has disappeared. In my case, it hasn’t caused the sort of problems you’re having, but I do get a LOT more crashes now than I did before.

Sorry I don’t have more useful input, but perhaps the two things are somehow related, and another party with more knowledge can chime in.

Thanks for that bit of info, your correct and the skip conversion option still works.