LCV4.1.5 accents in company names crashes

After the 4.1.5 openbeta update, my previous saves (with an ‘á’ in the company name) load to an empty UI. First I thought it’s broken due to some incompatibility, tried creating another carreer. It once again loaded onto an empty UI, trying to create a car crashed a game.
After that I noticed a scheme, (hungarian) accented characters seem to cause crashes, while the game works as expected with a more tame company name. I have a hunch this is related to the new SQLite backend. It’d be great to have it fixed
Update: I took the liberty of editing my save .db file. Seems like accents are fine everywhere, aside from the Game table’s GameName column. Accented company and factory names show up as before now, only the text in the campaign menu changed
Update 2: The staff got in touch with me on discord, I’ve shared my saves to reproduce the issue


I believe this is now fixed :slight_smile:

It is indeed, 4.1.7 fixed it. I wasn’t sure how to mark the topic as closed / solved

1 Like