LUA Error When Exporting 4x4 Vehicle, Undeletable Trim Variants

Hello! New to the forums. I used the search and was unable to find other reports of either of these issues, though I may have missed something. I likewise looked through the “known issues” page here on the forums and didn’t find anything. I figured I’d keep both of the issues in one place so as not to clutter things up with two new posts.

I am in the opt-in Alpha LCV4.2.31 and Beam 0.26.2

Issue 1: A very long LUA error pops up when attempting to export vehicles with a longitudinal 4x4 drivetrain into Beam. The export initially appears successful, but once you load the vehicle in Beam it is either extremely unstable, causing a near-instant “instability detected in vehicle” message from Beam or it simply has no drivetrain whatsoever and the body simply rests on the ground. I have tried this with several car bodies and engines, and the only unifying factor that seems to cause this issue is this drivetrain setup. All other drivetrains seem to export fine for me, though I haven’t tried them all. I have elected not to include the LUA error as it is extremely long, however I will happily provide it if it is requested.

Issue 2: (For clarity, this is in the sandbox mode under “Car Designer”) When cloning a car model and trim using the button just to the right of Revise (the button itself reading “Clone car Model and corresponding car Trims”) it clones as it should, however the game will refuse to properly delete the car if desired. When cloned initially the model name will read as “NAME Clone” and the trim will read as “TRIM Clone.” When attempting to delete the clone normally (i.e by selecting the vehicle to delete and then clicking the trash can icon) it will initially appear to be deleted. However, when selecting another menu and then returning to the Car Designer the vehicle will still exist, but its name will change, now reading “NAME” and “TRIM 2” respectively. If you attempt to Revise this vehicle the game will allow it, however it now believes it to be part of the original model, meaning chassis changes will change the original car too. Likewise, the game will not allow you to use any prior engines, and will force you to design a new one (I tried to edit it in order to trick the game into letting me delete it). Throughout this all no LUA errors pop up, there are no crashes or anything. If further information is required I’d be happy to provide, though I may need help in finding it- I’m not great with computers.

Thank you for taking the time to read through my issues! If either of these are known issues please let me know. I looked but I may have simply missed it. :slight_smile:

1 Like

Thanks for reporting these two, I can replicate both issues.

1 Like

Happy to! If I can provide any further information please let me know, though it seems like you’ve got all that you need. I’ll leave it in your capable hands! :grin:

I have just fixed the errant trims problem and potentially fixed the issue where deleting those trims could delete your original car project. Endfinity quickly found the exporter issue too. These fixes will be in the next hotfix!


Awesome! Sounds like it was a relatively simple fix, that’s good to hear. Looking forward to the next hotfix then! :grin: