.Net error and mods fail to process after 4.21

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.IO.IOException: Unable to get information about junction point. —> System.Runtime.InteropServices.COMException: Incorrect function. (Exception from HRESULT: 0x80070001)

— End of inner exception stack trace —

at Util.JunctionPoint.ThrowLastWin32Error(String message)

at Util.JunctionPoint.InternalGetTarget(SafeFileHandle handle)

at Util.JunctionPoint.Exists(String path)

at Automation_Launcher.AutomationLauncherWindow.LoadAllSteamMods()

at Automation_Launcher.AutomationLauncherWindow.Form1_Load(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Form.OnCreateControl()

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ScrollableControl.WndProc(Message& m)

at System.Windows.Forms.Form.WmShowWindow(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************


Assembly Version:

Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Automation Launcher Steam

Assembly Version:

Win32 Version:

CodeBase: file:///D:/Steam/steamapps/common/Automation/Automation%20Launcher%20Steam.exe


Assembly Version:

Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


Assembly Version:

Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll


Assembly Version:

Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


Assembly Version:

Win32 Version: 11.0.0

CodeBase: file:///D:/Steam/steamapps/common/Automation/Steamworks.NET.DLL


Assembly Version:

Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


Assembly Version:

Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll


Assembly Version:

Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C

CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll


Assembly Version:

Win32 Version:

CodeBase: file:///D:/Steam/steamapps/common/Automation/CefSharp.Core.DLL


Assembly Version:

Win32 Version:

CodeBase: file:///D:/Steam/steamapps/common/Automation/CefSharp.WinForms.DLL


Assembly Version:

Win32 Version:

CodeBase: file:///D:/Steam/steamapps/common/Automation/CefSharp.DLL

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging


For example:

<system.windows.forms jitDebugging=“true” />

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

No workshop items will load into the game as well.
So the game will register that mods are installed but will not process them and shows a blank black gray screen where it would normally show the mods installed/applied.
The game error says something about "Unable to get information about Junction Point"
Here is a picture of the game launcher https://imgur.com/a/NsPSBUw

Well, that sounds broken. Verify the game files, clear your game cache (button in launcher), and try to launch again. Could be something broken with the mods being loaded in. You can also try to remove them manually such they have to be updated.
Here is some more info in regards to mods: https://steamcommunity.com/app/293760/discussions/0/1842440600597452913/

I’m not sure if this is something that you guys need to look into or not but I think I fixed the mods not loading by deleting everything in the plugins folder of the game. EX: D:\Steam\steamapps\common\Automation\UE421\AutomationGame\Plugins

edit: nevermind… They appear to load but then the game crashes and when it restarts the game loses everything again.
Edit2: So I just noticed when I deleted everything in the plugins folder it created folders for each mod. Although they are empty and the game won’t launch…
Edit3: After deleting EVERYTHING including runtime and editor I can get the mods to appear but as expected the game does not launch and I get this error, which seems unusual… https://imgur.com/cOfPqPj
Edit4: After a clean steam reinstall the game still encounters the same error/issue.
Edit5: Even after unsubscribing to all the mods and resubscribing I get the same error. Verifying the game results in nothing happening besides steam saying I am all good. Is there some runtime or something that I could be missing?

Does your game launch without having subscribed to any mods?

Yes, It will launch without any of mods installed. It gives the error box, I can click continue, then It says the whole Mods Subscribed: 18 Mods Processed: 0 and then I can click PLAY and the game works just fine. I just am confused with the fact that it worked fine before the new update but now something is off?

Did you read the contents of the link I gave you? Have you subscribed to any of the offending mods?

I’ve unsubscripted to every mod on the workshop, deleted the contents of the the game then reinstalled and tried to install 1 mod titled “Banana wing” to test and I still get the same result. Mods Subscribed: 1 ; Mods Processed: 0

Is that mod actually compatible to UE4.21?

https://steamcommunity.com/sharedfiles/filedetails/?id=1164790499 Yes.

Interesting, works fine for me, launches, no problem.

So it must be something on the side of your system / software / folder setup specific to this. Let’s ask @zeussy about this.

I have a feeling I am missing some game runtime component in windows…? Although I am not sure what if that is even related to the problem. Just want to let you know that I appreciate everything that you have aided with so far and have loved all 215H I have played the game! I just do not want to lose the assets that the community has made and which I have fallen in love with.

That could indeed be the case, there is no obvious good reason for it to not work with loading mods. While we wait for zeussy to reply, you could check if your windows / antivirus has any restrictions on the plugins folder.

Just tested it, Can confirm that it is NOT the anti virus. Here is a Imgur album of what happens at every step before launching the actual game. https://imgur.com/a/4DbsJif

Edit 1: Curiously I downloaded the game on a older computer that I had lying around. It loaded the mods just fine. So I copied over ALL of the game files from that machine to the one I use regularly (the one I am having Issues with) and got the same error and the mods do not load, although they are all in the correct places.

(regarding the edit) Yepp, it has to do with your setup, its not a general thing.
Have you opted into the openbeta branch? We released an update that might help the issue.

I just opted into the branch and tried launching the game after clearing the cache, it still gives the exact same error message and the mods do not load… :frowning:

Edit1: just thought of something… What is it exactly that installs during the first time setup? Every time I’ve cleanly reinstalled the game it hasn’t dont that and I am wondering if I can somehow re-initiate that setup process…

Have a look here then:

The redistributables are listed there. The .Net framework install can now be the latest available one though, doesn’t have to be 4.5.2.

So I just reinstalled all of those (cleanly) and I still get the same issue… :confused:

Edit1: Could it be some error with my own .net installation? I’ve tried uninstalling it but I am not sure if I am doing it right or if it is even possible. Is there some way to repair it if it is wrong and do you know if there is any way to tell if it is wrong? I’ve tried pretty much every guide on youtube and the internet to no avial…

Edit2: Any more ideas on what I can do to fix this?

Here is a log file from the game if it helps… https://pastebin.com/06BGJnvu

holy smoly I FOUND THE SOLUTION! For some reason when the game is installed on an external HDD or a HDD other than the C Drive it fails to process mods.

An external HD definitely can cause issues! I have the game installed on drive D though while the documents folder is on drive C. Glad you found a solution, because the guy to help you out is in hospital right now :stuck_out_tongue: would take a while to get that sorted, so kudos to you for digging deeper!