No sound and cant export cars

hey guys, i have some issues i cannot for the life of me solve

i cannot hear any sounds in the game and it crashes when i try to export a car to beam.ng. It gets stuck on sourcing lua data.

i’ve tried uninstalling and resintalling, as well as verifying the files. any ideas what else i could do to remedy this?

after looking at the debug.log i’m noticing an error for locale_file_path.empty() and wondering if this is an issue?

here is a car i’m trying to export.

Model 2 - Trim 2.car (13.2 KB)

Add the Automation and BeamNG.Drive folders to your antivirus exception list. That might be what’s causing you issues.

good idea, but no dice.

also set all automation .exe’s to run as admin. didn’t help

Can we get an actual copy of the log?

this contains both debug.log and an automationgame.log from appdata

New WinRAR ZIP archive.zip (334.5 KB)

Thanks KilKidd,

Never seen this before. Although you said you have done a verify game files can I get you to check whether you have the following files:

For you the files should be found in “C:/Program Files (x86)/Steam/steamapps/common/Automation/WindowsNoEditor/AutomationGame/Content/FMOD/Desktop”

The issue is on startup FMOD Sound System is failing to load any of its sound banks. Which makes it seem like the files are not there. I know you have said you have done a verify. So Steam should have downloaded them. I just want to make sure.

yeah, all the files are there. same sizes as yours too.

fmod doesnt work in beamng either, if that helps any.

Looks like you have sound driver issues. Probably worth getting the latest drivers, or googling your sound device and problems with FMOD.

I am having the same problem I have reinstalled my sound drivers but i still have the same problem. I have no sound and when it is exporting it gets stuck at sourcing lua data. I am not using mods.this problem happens on other games such as Oxygen not included, Celeste and the emulator(all on steam).

Could I get an AutomationGame.log file from you? If you start Automation from the Launcher/Options tool you can click on Game Log Button to take you to it.


there it is.

ohh. there is a upload button.

Have you tried a Verify Integrity of Game Files… ?

The log states:

[2019.02.13-19.10.44:715][ 0]LogFMOD: Warning: Failed to bank: …/…/…/AutomationGame/Content/FMOD/Desktop/MasterBank.bank (An invalid object handle was used.)

If the MasterBank files to load, this will explain both of your symptoms