Ok, what did I screw up in this?

Other track makers have a look?
Why is this causing error:

Lua Error:

Step() failed!: [string “–client\functional\TrimDesignerWindow.lua…”]:4184: [string “–SANDBOX_DATA\CCarCalculator_TestTrack.lua…”]:414: attempt to perform arithmetic on a nil value

You can CTRL+C on this to report it.

Retry Cancel


---------------------------Kelly’s Mountain.zip (1.1 MB)
Forgot to upload track

Only on that track? Or the vanilla ones too?

The first segment has got a corner radius of 1 meter. No car can drive that. Try changing this value and it should work. I haven’t tested it though.

The track works, as-is, but, it goes over to the speedometer because of your starting direction. You really need to rotate the map. If you’re dead-set against map rotation, you’ll have to make your first section turn a lot wider, and maybe go more than 90 degrees even. I tried this on a track when I started…Bathurst(?) I think it was. It did not bode well at all!

EDIT: Your track distance is reported wrong on the map as well. It is 22.3km. I finished in a time of 7:03 with a random car.

1 Like

I had a feeling it was that first corner.
I didn’t put in the distance, that’s the GPS distance of actual travel.
I didn’t make this for competition, it’s just a local mountain we have to drive over to get to the rest of the country. So I drive it often. My little smart car (IRL) is balls out to hold the speed limit of 100 kph, in the steepest of sections, so it’s not defeating but it is certainly a workout. I was hoping to not have to rotate the map, I’ll see about fixing that corner radius. I figured it wouldn’t matter because the cars were barely moving and the turn was so short.
What’s the minimum safe radius? 10 meters?

Little off-topic: which track editor are you using?

Is there something newer and less clunky?

Sadly, no. I’ve faced a related issue where if the corner radius is small, combined with a high angle the entire thing goes wonky and the car doesn’t drive along the line you tell it to

Changed the opening to 20 m radius, still getting the error. :frowning:
Kelly’s Mountain.zip (1.2 MB)

Bleah, went through and found that there were a handful of 20m radius corners.
worked it over so that no corner is less than 30m radius. STILL getting the error.
I dunno, maybe the Car is sliding off the track? Don’t really wanna have to give up and start over but I can’t figure out what’s wrong… maybe the steep downhills are overheating the brakes and it’s flying through a corner faster than it should be able to, or something?

Rotate map. Start without the turn. This will solve at least 75% of your issues with the track. It is certainly possible to begin a track with a turn, but you are beginning the track with a 90 degree direction change, which just doesn’t work well. As for the error, it isn’t giving me an error on the first track. Are you sure it isn’t the car? Do you get any errors on other tracks?

If I may suggest, add a short straight to start the track. Seeing as you’ve used a Left turn as segment 0, add it just before ( I tested with a 15m straight, and shifted the start position X co-ordinate slightly to compensate)… It works.

EDIT: It half worked. A hypercar ran fine. A crap car error-ed like mad, a mid range car did the flappy throttle trick.

NOTE: Suggesting rotating a real life map is SACRILEGE, yes, I’m looking at you @07CobaltGirl

1 Like

It’s often had to be done. I’ve had to flip tracks that run counterclockwise because how else can I build it without the thing going bananas?

I don’t like to rotate maps, but it is a known limitation of the game currently. Track position starts along the X axis moving positive. Best solution is to work with the game. Anything else wrecks the times, at best, unless you make sector 1 the additional part to get the track in the correct direction, and at worst, it makes the game go batshit crazy. Ask me how I know…

As far as I know, the game supports rotated track since the test track revamp. Check this out: Hockenheim 1970
The parameter Start_Angle (unit: rad) can be used to rotate the track.



Shame we missed out on that, the dev for the track editor simply disappeared so of course we missed on that.


Ok. How do you know? :stuck_out_tongue: