[SOLVED] Engine breaks instantly in BeamNG no matter what car I put it in?

Hi all - having a problem with a certain engine of mine when exporting cars with it to BeamNG.

The engine works fine in Automation, but if I put it in a car and put that car in BeamNG, the engine ‘locks’/breaks the instant any acceleration is applied to it, whether the car is in gear or not.

I’ve put the engine in three completely different cars (as in different trims/completely different models) and it does the same thing every time. I’ve even written down the stats of the engine, then completely recreated it as a new model/variant and put THAT in various cars and the recreated version of the engine does the same thing…?

I am guessing it is an issue with how Automation exports the engine’s details to BeamNG?

The engine is a 650.5cc Inline-3 with 34hp. I wanted to use it to make some European and Japanese-style microcars…very frustrating!

What’s MORE frustrating is that it USED to work fine! I’ve had the same engine file in Automation for awhile now and cars with that engine always worked no problem in BeamNG until about a few versions ago (and I don’t know if that’s Automation or BeamNG versions, as I am not sure exactly when the issue started).

Anybody have any thoughts on how to fix this? :frowning:

EDIT: Just thought I would provide the engine details and see if anybody else wanted to recreate it exactly in their game as a new engine family/variant, shove it in a car and see if it instabreaks in their BeamNG game as well:


  • Year: 1972
  • Inline-3
  • Cast-iron Block
  • Family Capacity: 61.8 Bore, 72.3 Stroke (650.6cc)
  • Direct-Acting OHC
  • Cast-iron Head


Bottom End:

  • Year: 1972
  • Cast-iron Crank
  • Cast conrods
  • Hypereutectic Cast Pistons
  • Variant capacity: 61.8 Bore, 72.3 Stroke (650.6cc)
  • Quality: +5

Top End:

  • Compression 8.3:1
  • Cam Profile: 60
  • Quality: +5


  • Naturally Aspirated

Fuel System:

  • Single 2 Barrel Carb
  • Standard Intake
  • Regular 91 RON Fuel
  • 13.2 Fuel Mixture
  • Ignition Timing: 60
  • RPM Limit: 5800rpm
  • Quality: +5


  • Long Tubular Headers
  • 25.4mm Exhaust Diameter
  • Two-way Catalytic Converter
  • First Muffler: Straight Through
  • Second Muffler: Straight Through
  • Quality: +5

Try dropping the quality sliders to 0. I have seen some instances of the quality calculation causing errors in Beam for… reasons. Normally happens closer to +10, but that’s not a guarantee.

Just tried that - lowered all the quality sliders to 0 in the engine…no dice, still breaks in BeamNG with any acceleration in any car I put it in :face_with_raised_eyebrow::frowning_face:

I think the game has an issue if you use an engine that’s too small.

Was it made before or after update?

The engine file? Both!

I’ve used that same engine in previous versions of Automatioin and BeamNG, but somewhere in the last 2-3 version updates for either/or game, it instabreaks in BeamNG now. It used to work in BeamNG fine!

I’ve recreated an entirely new engine file with the exact same specs since the Automation and BeamNG updates within the last day or two and cars fitted with the new, recreated engine in BeamNG do the exact same thing - instabreak the second any acceleration is applied…?

@BobLoblaw Is that a new thing? The exact same engine always used to work fine in BeamNG before? It’s only somewhere in the last few Automation or BeamNG updates where it’s started breaking instantly in BeamNG.

Also, I would argue the engine can’t be ‘too small’ if ‘the game’ Automation allows you to make it by design…? If by ‘the game’ you mean BeamNG though, the Ishibu Pigeon minitruck, which is a stock vehicle in BeamNG uses a 658cc I3 engine and it’s fine in-game without breaking (my exported Automation engine is a 650cc I3, so barely any different…?)

It has to be a glitch/issue with the way Automation’s export is working if an incredibly similar engine is already in BeamNG proper and works fine there without breaking, or so logic seems to make me think? It’s all genuinely confusing to me… :confused:

If I remember correctly somebody was saying that lighter objects get weaker connections on nodes, so perhaps the mismatch between the vehicle weight and the engine weight means the engine torques itself off the frame?

Native BeamNG cars wouldn’t be effected as their node strength is set by the builder, rather than being calculated by the exporter.

1 Like

That sounds perfectly plausible…but then does that mean that the Automation folks changed something in the way engines are exported in cars to BeamNG considering my engine used to work fine…?

A turbo overhaul is coming at some point so perhaps it’s part of prepwork for more dynamic forced induction setups? It’s exciting times, any number of things could be changing for reasons we’ll never know.


I just hope they fix it…small cars are my jam, and it’s a bit frustrating to not have the thing I enjoy making the most not work in-game :frowning:

Maybe try a 4 cylinder and see if the higher smoothness stops it breaking.

1 Like

Don’t know if it’s been suggested already, but you can fix this by lowering the friction in the engine jbeam files to around 10. That way it won’t break.

You could also go larger, adding more cylinders doesn’t help, I had the same issues on a 1.6l v6

@Sky-High So you only fixed your issues by editing the engine file directly?

1 Like

im pretty sure it got fixed in the latest patch but i could be wrong.

That was a sure fire way of making it work yes.

Can’t be fixed in the latest patch unless one came out in the last 24 hours. I had tried completely re-making the engine as a new engine family/variant yesterday with exactly the same stats and it still instantly broke in BeamNG when I exported it.

UPDATE: Just checked - definitely still not fixed.

Are you on the openbeta branch of the game? If not, switch to it, because that issue is fixed there (to our knowledge).


Ooo, nope, I am on Stable Branch!

I’ll switch over and see if that does the trick - thanks for the response KillRob, I was unaware! :slight_smile:

Just wanted to reply and thank you KillRob - beta branch solved it! Thanks for all the hard work squashing bugs! :smiley:


Cheers mate! :slight_smile:


sorry to revive this thread, but I ended up with this bug again on the Open Beta branch. it is admittedly a meme car (200cc I3 in a minivan) but it just locks up instantly, same way a different car was doing before the fix.

Hwange_Van-X_-_Trim_28.car (25.4 KB)

EDIT: the same previous fix, lowering the dynamicFriction value in engine.jbeam, fixes it.