Top Speed Limitation

I just got the game recently and have made several cars so far. However, today I came across an issue and tried searching to see if other people have had a similar problem but I had no luck. Any car I create now has a limited top speed far below what the actual top speed should be. I have started with a fresh build several times, creating new engines, and even using engines that I previously had no problem with. For some reason it now seems that any car I make stops accelerating past a certain RPM in about 4th gear (almost as if the rev limiter was a few thousand RPMs lower). Even with I export the car and drive it in BeamNG it still has the issue. Any ideas?


Some screen shots from the game would be very helpful. I don’t know whether that may just be your car’s natural speed limit, or perhaps you accidentally enabled the electric speed limiter.

1 Like

I suspect it’s a mis-reading of the screen. Simply setting the diff ratio to “X” kmh versus looking at the max speed in the graph above. See if that makes sense in your case.

So I made a new campaign just to make sure it wasn’t something with my campaign that was glitched. I used the '85 race car body style and made a 4.5L turbocharged V12 that makes 1000hp and 820lp-ft of torque. I didn’t add anything to the body, just to make sure that wouldn’t cause a glitch somehow. There are no “Car & Engine Suggestions” that are red and would negatively affect the car. After I finished through all the settings I ran it on the test track and the motor gets stuck in 5th gear at ~7400RPMs and it won’t exceed 125mph, even when the track allows plenty of room for the car to continue to accelerate. Here is also a screenshot of the vehicle when exported to BeamNG. Even on the open grid map, the car will not accelerate past 126mph and ~7400RPMs.

Export the automation file, and I’m sure people will have a look at it for you (I’m not much of an engineer, but I am curious).

I’d love to upload it but it says that new users cannot upload files haha. I made another car since I made that last post and this is the first car today I have made that hasn’t had the speed glitch like I mentioned. I did made this new car is sandbox instead of in the campaign, so maybe that has something to do with it.

Can you also post a screenshot of the gearing graph in the Drivetrain tab, add the controller input widget onto your Beam UI, and also the ‘speed limit’ line from the engine.jbeam file which you can find from the documents/beamng/mods/your_vehicle_name/vehicles folder?

Here is a screenshot of the drivetrain tab. I can only add one image per post, but I did add the controller input widgets onto BeamNG and when it hits 126mph/~7400RPMs, the throttle input cuts down to 25-26%, even though I am not changing my input. Very odd. Also, the top speed limit line in the camso_engine.jbeam file says " “topSpeedLimit”:53.309642790715, //Speed limiter in m/s", which is ~120mph. Why does that line say that. Should I change it to be my theoretical top speed, or even above it? Or would changing it to whatever simply make my car insanely fast?

That’s weird. It should match the stipulated top speed in Automation. Just delete the line in the .jbeam entirely (you will need to unpack the mod to do this). Note that body Cd in Automation differs from Beam so the top speed may not match again.

You may run the mod by repacking it again or by placing it in a new folder within /mods called /unpacked

What size are the tires? Are they to narrow, or the wrong type?

Not sure if this is related or not, but it’s suspiciously close to that faulty top speed of yours:

That being said, I’ve had things on the graph like this before without any similar problems as you are experiencing.


12.5% wheelspin

1 Like

And that is with AWD and Electric LSD. On a 1800+kg car.
We need to see the tire setup to make a good guess on what’s wrong.

Same problem here. On new campaigns, no matter what type of car or engine, it always get stuck at 6.000 RPM on last gear. For example: If it is a 4 gear transmission, it will go above 6.000 in all gears, except fourth. It happens at the test track within Automation. I guess it will be the same exporting it to Beamng.